Layout no longer builds standalone on Win32

VERIFIED DUPLICATE of bug 57200

Status

SeaMonkey
Build Config
P3
normal
VERIFIED DUPLICATE of bug 57200
17 years ago
13 years ago

People

(Reporter: John McDonald, Jr., Assigned: use leaf@mozilla.org)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I am unable to compile nglayout as a standalone module for win32 at this point. 

By following this procedure, I am unable to compile...

cvs co mozilla/client.mak
cd mozilla
nmake -f client.mak pull_layout
nmake -f client.mak build_dist build_layout

The make fails with this message:
C:\mozilla\modules\libreg\src\reg.c(63) : fatal error C1083: Cannot open include
 file: 'prtypes.h': No such file or directory

Comment 1

17 years ago
->build config

Get on irc.mozilla.org and talk to `Sumner' in #mozillazine.  I believe he had 
the exact same problem yesterday and fixed it.
Assignee: asa → cls
Component: Browser-General → Build Config
QA Contact: doronr → granrose

Comment 2

17 years ago
windows.
Assignee: cls → leaf

Comment 3

17 years ago
layout requires nspr, and pull_layout doesn't pull nspr. Pull and build nspr in
the same mozilla tree, and this should work for you. Resolving invalid; reopen
if building nspr doesn't do the trick for you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

17 years ago
Building NSPR causes build to get much further, but now build fails when 
attempting to changedir to mozilla/db
Perhaps another dependency issue?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 5

17 years ago
If what you're looking for is a trimmed down layout engine, perhaps you want to
try the embedding build. I'm working to get this as easy as possible, but right
now it still involves pulling the whole tree.

If you'd like to track the progress, keep an eye on mozilla/embed.mak (for
windows). A side effect will be to produce viewer.exe, which is what layout
spits out. Making this bug assigned to me until you can use embed.mak to pull
what you need, in addition to building with it.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Updated

17 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
resolving as duplicate of 57200 (standalone embedding build) to clean up leaf's
bug list.  If you really want a standalone layout build, reopen and reassign to
yourself since leaf's not going to be working on this.

*** This bug has been marked as a duplicate of 57200 ***

Comment 7

17 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.