Closed Bug 626616 Opened 12 years ago Closed 12 years ago

book mark add popup doesn't allow focuse to be moved away from it.

Categories

(Firefox :: Bookmarks & History, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 4.0b12

People

(Reporter: tbsaunde, Assigned: hiro)

References

Details

(Whiteboard: [fixed in bug 545429])

User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b10pre) Gecko/20110117 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b10pre) Gecko/20110117 Firefox/4.0b10pre

When the add book mark popup is openyoucan't move focus away from it to say another window.

Reproducible: Always

Steps to Reproduce:
To reproduce this.
1. open the add bookmark popup with control -d 
2. try to alt tab or something similarto make the window manager change to a different window.  You should find you can't, and nothing happens.
Mozilla/5.0 (X11; Linux i686; rv:2.0b10pre) Gecko/20110119 Firefox/4.0b10pre

Confirmed. After pressing Ctrl+D, Unable to move another window by pressing Alt+Tab.
Notice that this is a linux specific issue. On Windows, alt+tab closes the dialog first and then switch windows.
karlt, this issue is also caused by the GrabKeyboard at there.
Status: UNCONFIRMED → NEW
Ever confirmed: true
When a menu (from menubar or context) is opened, the menu rolls up when the Alt key is pressed.  What ensures that?  And can we do something similar for this (and other) popups?
Depends on: 545429
Assignee: nobody → hiikezoe
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Whiteboard: [fixed in bug 545429]
Target Milestone: --- → Firefox 4.0b12
Works for me on:
Mozilla/5.0 (X11; Linux i686; rv:2.0b12) Gecko/20100101 Firefox/4.0b12
Considering Comment 5, setting resolution to Verified Fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.