Closed Bug 626685 Opened 9 years ago Closed 9 years ago

Assertion failure: compartment mismatched, at /work/mozilla/builds/2.0.0/mozilla/js/src/jscntxtinlines.h:541

Categories

(Core :: XPConnect, defect, critical)

x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 608987
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: cbook, Assigned: gal)

Details

(Keywords: crash, Whiteboard: hardblocker)

Attachments

(2 files)

While surfing with Firefox Trunk Debug Build on Mac 10.6 i was running into : 

*** Compartment mismatch 0x2fe0fe00 vs. 0x38843e00
Assertion failure: compartment mismatched, at /work/mozilla/builds/2.0.0/mozilla/js/src/jscntxtinlines.h:541
Bus error

not much tabs open (about 5) including some stuff like google, moco zimbra etc 


Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
0   XUL                           	0x01ba933c JS_Assert + 85
1   XUL                           	0x01b8f939 js::CompartmentChecker::fail(JSCompartment*, JSCompartment*) + 73
2   XUL                           	0x01b8f990 js::CompartmentChecker::check(JSCompartment*) + 80
3   XUL                           	0x01b4342e js::CompartmentChecker::check(JSObject*) + 38
4   XUL                           	0x01a2e1f4 void js::assertSameCompartment<JSObject*>(JSContext*, JSObject*) + 59
5   XUL                           	0x01a0a746 JS_GetPrototype + 168
6   XUL                           	0x00a1722c IsObjInProtoChain(JSContext*, JSObject*, JSObject*) + 79 (nsDOMClassInfo.cpp:9553)
7   XUL                           	0x00a17e49 nsHTMLPluginObjElementSH::SetupProtoChain(nsIXPConnectWrappedNative*, JSContext*, JSObject*) + 613 (nsDOMClassInfo.cpp:9641)
8   XUL                           	0x00445a8c nsObjectFrame::NotifyContentObjectWrapper() + 428 (nsObjectFrame.cpp:2712)
9   XUL                           	0x00445b43 nsObjectFrame::TryNotifyContentObjectWrapper() + 125 (nsObjectFrame.cpp:2446)
10  XUL                           	0x006d9020 nsObjectLoadingContent::OnStartRequest(nsIRequest*, nsISupports*) + 4742 (nsObjectLoadingContent.cpp:761)
11  XUL                           	0x0017dcfc nsHttpChannel::CallOnStartRequest() + 1180 (nsHttpChannel.cpp:770)
12  XUL                           	0x0017e342 nsHttpChannel::ContinueProcessNormal(unsigned int) + 642 (nsHttpChannel.cpp:1228)
13  XUL                           	0x0017e4c9 nsHttpChannel::ProcessNormal() + 239 (nsHttpChannel.cpp:1165)
14  XUL                           	0x00182f44 nsHttpChannel::ProcessResponse() + 814 (nsHttpChannel.cpp:1052)
15  XUL                           	0x00183514 nsHttpChannel::OnStartRequest(nsIRequest*, nsISupports*) + 664 (nsHttpChannel.cpp:3876)
16  XUL                           	0x0007e6b6 nsInputStreamPump::OnStateStart() + 186 (nsInputStreamPump.cpp:441)
17  XUL                           	0x0007f45e nsInputStreamPump::OnInputStreamReady(nsIAsyncInputStream*) + 122 (nsInputStreamPump.cpp:397)
18  XUL                           	0x017e6556 nsInputStreamReadyEvent::Run() + 100 (nsStreamUtils.cpp:113)
19  XUL                           	0x01814ddf nsThread::ProcessNextEvent(int, int*) + 907 (nsThread.cpp:633)
20  XUL                           	0x01798d31 NS_ProcessPendingEvents_P(nsIThread*, unsigned int) + 146 (nsThreadUtils.cpp:200)
21  XUL                           	0x0146a42b nsBaseAppShell::NativeEventCallback() + 181 (nsBaseAppShell.cpp:133)
22  XUL                           	0x01418555 nsAppShell::ProcessGeckoEvents(void*) + 497 (nsAppShell.mm:400)
23  com.apple.CoreFoundation      	0x9055d4cb __CFRunLoopDoSources0 + 1563
24  com.apple.CoreFoundation      	0x9055af8f __CFRunLoopRun + 1071
25  com.apple.CoreFoundation      	0x9055a464 CFRunLoopRunSpecific + 452
26  com.apple.CoreFoundation      	0x9055a291 CFRunLoopRunInMode + 97
27  com.apple.HIToolbox           	0x9557d004 RunCurrentEventLoopInMode + 392
28  com.apple.HIToolbox           	0x9557ccf7 ReceiveNextEventCommon + 158
29  com.apple.HIToolbox           	0x9557cc40 BlockUntilNextEventMatchingListInMode + 81
30  com.apple.AppKit              	0x942c278d _DPSNextEvent + 847
31  com.apple.AppKit              	0x942c1fce -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 156
32  com.apple.AppKit              	0x94284247 -[NSApplication run] + 821
33  XUL                           	0x01417253 nsAppShell::Run() + 291 (nsAppShell.mm:746)
34  XUL                           	0x011567be nsAppStartup::Run() + 148 (nsAppStartup.cpp:217)
35  XUL                           	0x0003f7a9 XRE_main + 11884 (nsAppRunner.cpp:3699)
36  org.mozilla.firefoxdebug      	0x000025f1 main + 714 (nsBrowserApp.cpp:158)
37  org.mozilla.firefoxdebug      	0x00002272 start + 54
blocking2.0: --- → ?
blocking2.0: ? → betaN+
Whiteboard: hardblocker
Assignee: general → nobody
Component: JavaScript Engine → XPConnect
QA Contact: general → xpconnect
Attached patch patchSplinter Review
Assignee: nobody → gal
Attachment #504825 - Flags: review?(jst)
Andreas, the patch in bug 608987 would fix this as well, would it not?
Yeah, this is a dup.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 608987
Attachment #504825 - Flags: review?(jst)
You need to log in before you can comment on or make changes to this bug.