When downloading an add-on with unsaved edits, we must save before creating/sending the XPI

VERIFIED FIXED in Builder 0.9.1

Status

P1
blocker
VERIFIED FIXED
8 years ago
4 years ago

People

(Reporter: dbuchner, Assigned: zalun)

Tracking

unspecified
Builder 0.9.1

Details

(Reporter)

Description

8 years ago
Currently, if you edit code files on an add-on in the Builder and then try to download the add-on without manually hitting save first, the add-on XPI is created with out-of-date code.
(Reporter)

Updated

8 years ago
Severity: normal → blocker
Priority: -- → P1
Target Milestone: --- → Builder 0.8
(Assignee)

Comment 1

8 years ago
Or disable Download button if edited. 

Also we need an additional button which would reset current changes. I will try to switch the edited back on - just after the ACE integration
(Reporter)

Comment 2

8 years ago
Uhh, no I think clicking download should just fire a save event if the flag for unsaved is present. If you want to wait for ACE so that you don't have to do rework that is fine, but disabling like that is terrible UX...
(Reporter)

Updated

8 years ago
Assignee: nobody → zaloon
(Assignee)

Comment 3

8 years ago
We agreed to have a modal displayed if code was changed. User will have 3 options.
[Save&Download] [Download without saving] [Cancel]
(Reporter)

Updated

8 years ago
Target Milestone: Builder 0.8 → Builder 0.9
(Reporter)

Updated

8 years ago
Duplicate of this bug: 626764
(Reporter)

Updated

8 years ago
Duplicate of this bug: 626329
Why would a user ever want to download without saving?
(Assignee)

Comment 7

8 years ago
No idea - but I think it's bad to autosave, so maybe no [download without saving] button
(Reporter)

Comment 8

8 years ago
I can see a use-case where a user loses track of what they are doing mid-edit and tries to download a file that will inevitably break, though to Wil's point, I don't think this will be a common case.

Let's go ahead and give them the three choices: [Save & Download] [Download without saving] [Cancel]
Target Milestone: Builder 0.9 → Builder 0.9.1
(Assignee)

Comment 9

8 years ago
https://github.com/zalun/FlightDeck/commit/2708d0d8c56455d4d0371c52143cbac316ae97fd

Fixed - the only thing to check is the text.
For "default" style in the default button another bug will be filed
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
In the future please like to commits on mozilla/flightdeck and put the bug number in the commit messages.  thanks
follow up bug filed - https://bugzilla.mozilla.org/show_bug.cgi?id=644326
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.