Status

defect
RESOLVED INVALID
8 years ago
3 years ago

People

(Reporter: dsmith, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110118 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110118 Firefox/4.0b10pre

OK, I was testing out the fix for Panorama impacting UI responsiveness, and I got more strangeness happening.

First, every second entry into Panorama (select tab from pana, immediately return to pana using toolbar icon, select tab to return to browser, repeat) created an odd grey bar at the bottom of the Panorama screen: http://img502.imageshack.us/i/large2grey.png/

I can't figure out what the stuff under the grey bar is supposed to be. It doesn't appear to be an opaqued view of any program window or browser tab I have open right now.

Second, every single entry into Panorama seemed to increase the thumbnail size of the collected tabs. Took a bit to notice, but a dozen repeats of the cycle seemed to increase their size by about 50% (ie: they were about 2/3 their current size, originally): http://img249.imageshack.us/i/largethumbnails.png/

Third, the blank thumbnails in the Panorama view always remained blank. They never got the thumbnail view resolved.

Reproducible: Always

Steps to Reproduce:
1. See Details.

Actual Results:  
Growing thumbnails, unresolved thumbnail images, anomalous grey bar.

Occurs with a clean restart of the browser; have not yet tested with new profile.

Expected Results:  
Consistent thumbnail size, resolved thumbnail images, no grey bar.
(Reporter)

Comment 1

8 years ago
Per suggestion, added bas.schouten@live.nl to cc list (assuming I did it right) as he was doing work on the previous Panorama issue.
(Reporter)

Comment 2

8 years ago
Extra note: have had an incidence of the 'grey bar' showing the bottom part of an open Firefox (not Minefield) window that I can definitely identify.  Comparing with the screenshotted version, I think the screenshot had two windows showing through which was what confused me.

So the grey bar is a chunk of 'glass' from Win7's aero showing stuff behind the Minfield window.
(Reporter)

Comment 3

8 years ago
Ok, grey box issue is likely to be related to bug 612232
(Reporter)

Comment 4

8 years ago
Grey box issue also likely related to bug 617076, which seems to have more general activity.
Blocks: 627096
David, thanks for your bug! Let's try to split this up into individual issues (one issue per bug), though:

> First, every second entry into Panorama (select tab from pana, immediately
> return to pana using toolbar icon, select tab to return to browser, repeat)
> created an odd grey bar at the bottom of the Panorama screen:
> http://img502.imageshack.us/i/large2grey.png/
> 
> I can't figure out what the stuff under the grey bar is supposed to be. It
> doesn't appear to be an opaqued view of any program window or browser tab I
> have open right now.

As others note, this is bug 612232.

> Second, every single entry into Panorama seemed to increase the thumbnail size
> of the collected tabs. Took a bit to notice, but a dozen repeats of the cycle
> seemed to increase their size by about 50% (ie: they were about 2/3 their
> current size, originally): http://img249.imageshack.us/i/largethumbnails.png/

Could you show us a video or something of this? When I look at that screenshot, it looks perfectly normal to me.

> Third, the blank thumbnails in the Panorama view always remained blank. They
> never got the thumbnail view resolved.

Are you describing this situation on startup? What if you go into a tab and reload it? Or is it specific tabs? I ask because there are of course perfectly normal thumbnails in the screenshots you provided.
(Reporter)

Comment 6

8 years ago
(In reply to comment #5)

> > Second, every single entry into Panorama seemed to increase the thumbnail size
> > of the collected tabs. Took a bit to notice, but a dozen repeats of the cycle
> > seemed to increase their size by about 50% (ie: they were about 2/3 their
> > current size, originally): http://img249.imageshack.us/i/largethumbnails.png/
> 
> Could you show us a video or something of this? When I look at that screenshot,
> it looks perfectly normal to me.

They're displayed normally, but the pixel size of each thumbnail increases per iteration.  You'll note that in the screenshots the groups take up about 2/3 of the screen width; the initial sizing was under half the screen width.

However I can't seem to reproduce the effect in today's build.  May have been fixed?

> 
> > Third, the blank thumbnails in the Panorama view always remained blank. They
> > never got the thumbnail view resolved.
> 
> Are you describing this situation on startup? What if you go into a tab and
> reload it? Or is it specific tabs? I ask because there are of course perfectly
> normal thumbnails in the screenshots you provided.

On startup, per use, reloading each page, selecting thumbnail, etc, never generated an image.  In the screenshots there are 3 that worked, but none of the rest did.

It seems partly corrected today in that many of the thumbnails are now generating images if I select them from the Panorama screen, but not all of them will (including, again, using selection/reload/etc).  Today, using the same pages as in the screenshot, all but 4 will generate thumbnail images.  Those 4 are one forum thread and 3 private messages in the bottom tab group (tabs 2-5).

Not sure if it would be useful at all, but the link to the forum thread for one of the non-thumbnailing tabs is http://www.bluegartr.com/threads/84032-Relics-Xtimes-damage-proc-rate-testings?p=3220952&viewfull=1#post3220952
(Reporter)

Comment 7

8 years ago
Addendum to above: After a couple restarts, in and out of private mode, and misc other browsing, the link noted above shows up as a thumbnail.  So, it's not that link specifically, but something about the browser state that was preventing it.  Unfortunately I now have no way of replicating it, so not sure how to figure out what was going wrong.
I've noticed that thumbnails sometimes don't generate, I think it has something to do with code that sort of disabled constant updating recently.  Don't know if there is a bug filed or fixed though.
(Reporter)

Comment 9

8 years ago
I'm not sure what bug it's related to (doesn't seem to match up with the bugs I'd found, and they're not marked as fixed either, but there were a number of TabCandy patches that landed today), but it appears something was changed for the background of the Panorama screen so now everything except the tab groups is 'glass' in Win7/Aero.

Assuming this is intentional, the problem in this bug with the grey bar appears to be completely negated.

I have not had any further occurrences of the thumbnail resizing.

And, with the exception of a positioning glitch (which I don't know if there's another bug for), the thumbnails all appear to be showing up properly.

As such I guess this bug can be closed.  Not sure which status tags to use for it, though, so I'll leave it to someone more familiar.
Resolving. Let us know if you see these things again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
David,

With Win7 Panorama is suppose to be glass with Aero Glass now (bug 591652).

The grey bar (bug 612232) is probably still an issue since Panorama is different if not using Aero Glass.

The thumbnail resizing also might have been fixed by bug 624953.
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.