Mozilla Labs Feedback Addon using excessive memory (55MB)

RESOLVED WONTFIX

Status

P1
blocker
RESOLVED WONTFIX
8 years ago
2 years ago

People

(Reporter: orangezilla, Unassigned)

Tracking

unspecified
x86
Windows 7

Details

(Whiteboard: performance, [MemShrink], URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: Firefox/4.0b9

Increased memory usage reported with Firefox 4 Beta 9 over FF 3.6 is partly due to the Feedback addon, found to use between 53-57MB extra memory vs all addons disabled, see these two threads:

http://forums.mozillazine.org/viewtopic.php?f=23&t=2076797&start=15
http://forums.mozillazine.org/viewtopic.php?f=23&t=2068415&start=75



Reproducible: Always

Steps to Reproduce:
1. Manually disable all addons or Help>Restart with Addons disabled
2. Wait 10-15 seconds for CPU cycling of Firefox.exe to die down, then note down memory usage using about:memory or Process Explorer.
3.Enable Feedback Addon, wait 10-15 seconds, and note down memory as before.
Actual Results:  

1 tab (Bing) 53.3MB all addons disabled

1 tab (Bing) 106.3MB FF feedback addon enabled

5 tabs all addons disabled 91.5MB

5 tabs + ABP 115.7MB

5 tabs + Mozilla feedback 148.8MB

Expected Results:  
Feedback Addon should not add that much memory overhead
(Reporter)

Comment 1

8 years ago
About:memory shows around a 21.5MB increase in storage/sqlite/pagecache with feedback addon enabled vs all addons manually disabled with 6 tabs

See latest posts here

http://forums.mozillazine.org/viewtopic.php?f=23&t=2076797&p=10329959#p10329959
(Reporter)

Comment 2

8 years ago
Memory usage seems to be down to user study "A Week In the Life of A Browser - Version 2" https://testpilot.mozillalabs.com/testcases/aweeklife2 

given that study measures memory usage & tabs open, it would seem the 55MB + upwards additional overhead of the study will skew the readings

Updated

8 years ago
Whiteboard: performance

Updated

8 years ago
Severity: normal → critical
Priority: -- → P1
Target Milestone: --- → 1.2

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

8 years ago
Severity: critical → blocker
Target Milestone: 1.2 → 1.3
Whiteboard: performance → performance, [MemShrink]
This is old, FF7 (currently in beta) fixes lots of problems, and that Test Pilot study is long-past.  There doesn't seem to be much point leaving this bug open.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.