plugins are clipped out of the update region when page is scrolled

VERIFIED DUPLICATE of bug 59620

Status

()

Core
Plug-ins
P3
normal
VERIFIED DUPLICATE of bug 59620
18 years ago
17 years ago

People

(Reporter: sean echevarria, Assigned: Peter Lubczynski)

Tracking

Trunk
mozilla0.8
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Mac plugins get clipped out of the update region when the page they are in is 
scrolled.  Painting during null events fails to update the screen after the 
page has been scrolled.

Once in the new position, an UpdateEvt is necessary for region to be fixed (for 
instance selecting the text above and below the plugin or moving another 
application window on top of the plugin and then removing it).

Key to reproducing this is that the plugin must be substantially smaller than 
the visible area of the browser, so that scrolling the page causes the plugin 
to go from the top of the page to the bottom and the distance traveled is 
larger than the height of the plugin.

Brian Nesse has a mac port of the simple plugin that can be used to reproduce 
this.
(Reporter)

Updated

18 years ago
Keywords: beatnik

Comment 1

18 years ago
reassign:peterl, I think there is a bug already logged for this..
Assignee: av → peterl
(Assignee)

Comment 2

18 years ago
I think this is a dup, but not sure of which one. Marking Mozilla 0.8 anyway.
Target Milestone: --- → mozilla0.8

Comment 3

18 years ago
ok, found it. This is a dup of 57189

*** This bug has been marked as a duplicate of 57189 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
oops bug 57186 actually.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 5

18 years ago

*** This bug has been marked as a duplicate of 57186 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

18 years ago
bug 57186 is a dupe of bug 53853.
This bug is not a dupe of 53853.

This bug is not about garbage being left behind or trailing on the window.
This bug is about plugins getting clipped out of the udpate region when the 
window scrolls - no garbage trails occur, just a stagnated rect that is no 
longer updated.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 7

18 years ago
I reacted too quickly.  It appears there is a fix in the branch for bug 57186 
but not on the trunk.  If that is correct then maybe that WILL fix this one.  
If the fix is already on the trunk then it does not address this one.
(Assignee)

Comment 8

18 years ago
Changing peterl-retired to peterlubczynski
Assignee: peterl-retired → peterlubczynski
Status: REOPENED → NEW
(Assignee)

Comment 9

18 years ago
Brian, think calling FixUpMacWindow() and SetWindow() after scrolling would fix
this?

Comment 10

18 years ago
This bug is is very fixable via a call to FixUpPluginWindow(), one call added in 
the Notify method of nsPluginInstanceOwner does the trick nicely (and fixes some 
other updating while scrolling issues as well.) I'd post a patch, but it would be 
dependent on the patch for 59620.
Depends on: 59620

Comment 11

18 years ago
Actually, after thinking more about it, this is really an extension of 59620. Any 
fix for 59620 should also insure that the coordinate information is also valid 
when NULL events are passed. Marking as a duplicate of 59620.


*** This bug has been marked as a duplicate of 59620 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
No longer depends on: 59620
Resolution: --- → DUPLICATE

Comment 12

18 years ago
well, I was verifying 59620 on the branch and trunk on mac and still see that 
quicktime movies(quicktime.com/trailers) do get clipped out and page does not 
update when I scroll. Sean, can you please check this? Thanks!

Comment 13

18 years ago
actually, works fine for beatnik player..

Comment 14

17 years ago
marking verif dup
Status: RESOLVED → VERIFIED

Updated

17 years ago
Keywords: beatnik
You need to log in before you can comment on or make changes to this bug.