Need a way to manage test cycles

VERIFIED FIXED in 0.2

Status

Mozilla QA
MozTrap
P1
enhancement
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

unspecified

Details

Attachments

(1 attachment, 2 obsolete attachments)

153.24 KB, image/png
Details
(Reporter)

Description

8 years ago
Created attachment 504941 [details]
mock-up

The TCM will need a pane for test cycle management. In this pane, the
following will be needed:

* A table of results entries with values shown for creation date, id, title, state.
* Default list of 20 results shown.
* A combobox to set the number of results per page going from 10,20,50 and 100.
When selected, the page should AJAX-ily update the listings area rather than
require a new page load.
* A checkbox per row entry when a logged in user is an admin
* Pagination that allows users to go to a certain page and to the beginning and
end of the set of results AJAX-ily.
* Edit (goes to individual test cycle create/edit page) and Remove (offers a dialog
to confirm whether to remove the test cycle or not...then deletes that cycle if
confirmed) hyperlinks are available per test cycle entry.
(Reporter)

Updated

8 years ago
Target Milestone: 0.3 → 0.2
(Reporter)

Comment 1

8 years ago
Created attachment 512324 [details]
mock-up

Remove "State" as its not in the data model. It only applies to Test Runs; not test cycles.
Attachment #504941 - Attachment is obsolete: true
(Reporter)

Comment 2

8 years ago
Created attachment 512343 [details]
mock-up

sigh the previous one was a bmml file
Attachment #512324 - Attachment is obsolete: true

Comment 3

8 years ago
* Add "start date" and "end date" to displayed columns, perhaps remove "creation date" and "id"?
* We need an API call for the "clone" action.
(Reporter)

Comment 4

8 years ago
> Add "start date" and "end date" to displayed columns, perhaps remove
"creation date" and "id"?

Replacing creation date with start/end date works; I'd like to keep id though. 

> We need an API call for the "clone" action

Will do on the PRD
(Reporter)

Comment 5

8 years ago
Actually, removing id is fine too.

Updated

8 years ago
Whiteboard: [API?]

Comment 6

8 years ago
>Remove "State" as its not in the data model. It only applies to Test Runs; not
>test cycles.

Hmm. I would think it has a state of at least active and completed. Or will the test cycle state be derived from it's test runs.

Comment 7

8 years ago
Test cycles do have their own state; the same set of possible states as a test run, actually.

Comment 8

8 years ago
then we should display the value.

Comment 9

8 years ago
Since it looks like the bulk actions are not part of .2, we're going to leave the checkbox-per-row out for now as well since it would have no purpose yet.
(In reply to comment #9)
> Since it looks like the bulk actions are not part of .2, we're going to leave
> the checkbox-per-row out for now as well since it would have no purpose yet.

Uh, not sure what I was smoking there. Yes, these bulk actions are in .2, see https://bugzilla.mozilla.org/show_bug.cgi?id=627163
(In reply to comment #0)
> * Edit (goes to individual test cycle create/edit page) and Remove (offers a
> dialog
> to confirm whether to remove the test cycle or not...then deletes that cycle if
> confirmed) hyperlinks are available per test cycle entry.

In general, we'd opt for undoable deletes (see https://bugzilla.mozilla.org/show_bug.cgi?id=635031) rather than confirmation popups. UX research is pretty clear that undo is preferable to confirm; confirm just gets in your way all the time, and so you train yourself to mentally ignore it and confirm automatically, so it ends up not serving any purpose at all.
(Reporter)

Comment 12

8 years ago
> UX research is pretty clear that undo is preferable to confirm; confirm
> just gets in your way all the time, and so you train yourself to mentally
> ignore it and confirm automatically, so it ends up not serving any purpose at
> all.

Works for me!
Removing [API?] marker here, clone is moved out of 0.2 scope (but still in 1.0 scope).
Whiteboard: [API?]
Just noting that all list views will also include a filtering / faceting interface for narrowing the viewed list by e.g. product, state, ....
(Reporter)

Comment 15

8 years ago
For Carl: We won't need bulk actions on this panel anymore with the new mock-up.
(Reporter)

Comment 16

8 years ago
Now that we're going to include a drop down, we'll need to re-organize the data a bit. So, here's the details for it for a test cycle:

top-level: title, status (icon/image), start date, end date
pop-down level: id, description, creation date, created by, environment, testers

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Looks great!  Tastes even better.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.