Provide an option to permanently hide the addon bar

RESOLVED INVALID

Status

()

Firefox
Toolbars and Customization
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Ben Lerner, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

When I dismiss a toolbar, and restart Firefox, I expect that toolbar to stay hidden.  The addon bar keeps coming back.  I don't know whether this is a Fx4b9 bug, or the addon bar is still in flux and this is an enhancement request, or if this is permanent UI...

(I got into the habit of hiding any status bar at the bottom of my laptop screen because it was aging poorly, and leaving the bar there actually caused screen burn-in...  Now I'm used to not needing the status bar at all.)

Ideally, I'd like the option to have a toolbar button I could add to the addressbar, similar to the Show/hide bookmarks bar button, that would show/hide the addons bar.

Reproducible: Always

Steps to Reproduce:
1. Launch Fx
2. Close the addon bar
3. Restart Fx
Actual Results:  
The addon bar comes back...

Comment 1

8 years ago
Once you close the add-on bar the bar stays hidden until you activate it once again

Please try if you can reproduce it or if it works fine

1.in safe mode. 
https://support.mozilla.com/en-US/kb/Safe+Mode

2.or by creating a new profile
https://support.mozilla.com/en-US/kb/Managing+profiles#Creating_a_profile
(Reporter)

Comment 2

8 years ago
It's true that in a new test profile the addon bar stays hidden, but I also thought that the addon bar stays hidden when no extensions are installed/enabled -- which is precisely what's missing in either safe mode or a new profile, right?

Thinking that it might be a migrated-settings issue, I tried asking Fx to reset all preferences in my standard profile.  That did indeed reset all preferences, caused first-run experiences to reappear, etc etc, but the addon bar still reappears each time.  What preference (about:config or otherwise) controls whether it appears or not?  Also, could it be extensions themselves forcing it back into view?  (I hope not; that's rude of them...)
(In reply to comment #2)
> Also, could it be extensions themselves forcing it
> back into view?  (I hope not; that's rude of them...)

There's a Bug (somewhere) about Firebug doing that.
(Reporter)

Comment 4

8 years ago
Thanks for the heads-up.  A bit of searching (now that I knew where to look) yielded http://code.google.com/p/fbug/issues/detail?id=3556 as the known issue.

Resolving as INVALID, since this isn't a Fx issue per se.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.