Closed Bug 627039 Opened 11 years ago Closed 7 years ago

nagios check for win64 nightly builds

Categories

(Release Engineering :: General, defect, P4)

x86_64
Windows 7
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: armenzg, Unassigned)

References

Details

(Whiteboard: [win64][nagios])

Attachments

(1 file)

Could you please add a nagios check to like we have for the win32 nightly builds?

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/firefox-4.0b10pre.en-US.win64-x86_64.installer.exe

Only for mozilla-central and tracemonkey branches for now (or do all branches if it is easier and we will ACK to a bug)

Thanks!
Assignee: server-ops → server-ops-releng
Component: Server Operations → Server Operations: RelEng
QA Contact: mrz → zandr
We can do this ourselves. It's a change to 
  mozilla/tools/tinderbox-configs/monitoring/Firefox_mozilla-central.txt
and Firefox_tracemonkey.txt in cvs.mozilla.org/cvsroot.

I'd question whether we should until we have a finalised refplatform and machines connected to production buildbot masters.
Assignee: server-ops-releng → nobody
Component: Server Operations: RelEng → Release Engineering
QA Contact: zandr → release
Right now, nightly builds is the only way to catch a compilation regression.
We have caught already 2 of them on January.
Assignee: nobody → armenzg
OS: Mac OS X → Windows 7
Priority: -- → P3
Hardware: x86 → x86_64
Whiteboard: [win64][nagios]
looks like 3 in janurary now no builds are available for download
True. Yesterday's nightly failed. I will get to it and to this bug this week.
My hands are full right now.
Whiteboard: [win64][nagios] → [win64][nagios] ETA: week of 7th of Feb.
Priority: P3 → P2
Currently a lot of people rely on the win64 nightly builds and I get poked about it every time they fail.

I am planning on having a win64 nightly builds running on the real production masters rather than on staging.
Attachment #509781 - Flags: review?(nrthomas)
Comment on attachment 509781 [details] [diff] [review]
[CVS/tools/tinderbox-configs] add nagios checks for win64 nightly builds

I don't think we should add these lines, even if we were to s/win64/win64-x86_64/ so they worked. We should continue to treat any win64 issues as a very low priority, and work on getting production machines up on production masters. Both of those are lower priority than any Fx4 work.

Otherwise we will end up with nagios complaining about win64 for more than one day, and someone will ack the nagios alert. If any of the files we really care about get stale then nagios won't complain again, and we don't want to be in that state. If you really want some sort of automated check you can ask IT to set up a new check using a different control file, and only add the win64 files (or just hack up something temporary using cron).
Attachment #509781 - Flags: review?(nrthomas) → review-
I will hack a cronjob. No worries.
Whiteboard: [win64][nagios] ETA: week of 7th of Feb. → [win64][nagios]
Priority: P2 → P4
Indiscriminate ack'ing needs to stop, anyway!
Priority: P4 → P5
Whiteboard: [win64][nagios] → [win64][nagios][q1goal]
Priority: P5 → P3
Is there anything for IT to do on this bug, or should it go back to releng?  If there is a request for IT, can someone please clarify what it is?
Nothing for IT to do here, and it's in our component already.
Priority: P3 → P4
Nothing to be done until bug 647287 is fixed.
Assignee: armenzg → nobody
(In reply to Armen Zambrano G. [:armenzg] from comment #11)
> Nothing to be done until bug 647287 is fixed.

Bug you've mentioned is fixed now.
Product: mozilla.org → Release Engineering
Blocks: re-nagios
Component: Other → Tools
QA Contact: hwine
Whiteboard: [win64][nagios][q1goal] → [win64][nagios]
We actually did away with this type of nagios check.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
Component: Tools → General
You need to log in before you can comment on or make changes to this bug.