Status

addons.mozilla.org Graveyard
Code Quality
P5
normal
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: clouserw, Assigned: jbalogh)

Tracking

unspecified
5.12.8

Details

(URL)

(Reporter)

Description

7 years ago
Jgrlicky is trying to design our mobile buttons but can't load the smorgasbord:

/z/en-US/firefox/addons/smorgasbord

Traceback (most recent call last):

 File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/core/handlers/base.py", line 109, in get_response
   response = callback(request, *callback_args, **callback_kwargs)

 File "/data/amo_python/www/preview/zamboni/apps/addons/buttons.py", line 296, in smorgasbord
   disabled_by_user=False)[0])

 File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/db/models/query.py", line 190, in __getitem__
   return list(qs)[0]

IndexError: list index out of range
(Reporter)

Updated

7 years ago
Priority: -- → P5
(Assignee)

Updated

7 years ago
Duplicate of this bug: 625907
(Assignee)

Comment 2

7 years ago
https://github.com/jbalogh/zamboni/commit/7a7ece7
Assignee: nobody → jbalogh
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.