Last Comment Bug 627113 - Thin line on the right edge of the window on pressing "right" button in panorama
: Thin line on the right edge of the window on pressing "right" button in panorama
Status: VERIFIED FIXED
:
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: Trunk
: x86 Windows 7
: -- normal
: Firefox 6
Assigned To: Adam [:hobophobe]
:
:
Mentors:
: 648995 (view as bug list)
Depends on:
Blocks: 597269
  Show dependency treegraph
 
Reported: 2011-01-19 10:48 PST by Siddhartha Dugar [:sdrocking]
Modified: 2016-04-12 14:00 PDT (History)
7 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screenshot for comparison (55.30 KB, image/png)
2011-01-19 10:51 PST, Siddhartha Dugar [:sdrocking]
no flags Details
Solves line appearance issue by adding overflow: -moz-hidden-unscrollable to #content, as suggested by mitcho. (412 bytes, patch)
2011-04-12 12:43 PDT, Adam [:hobophobe]
ian: review+
Details | Diff | Splinter Review
Same patch, but prepared for pushing. (709 bytes, patch)
2011-04-15 11:00 PDT, Adam [:hobophobe]
no flags Details | Diff | Splinter Review

Description Siddhartha Dugar [:sdrocking] 2011-01-19 10:48:28 PST
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110119 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110119 Firefox/4.0b10pre

Open an app tab in a new window
Enter, exit and re-enter panorama using panorama button
Hit the right arrow button on keyboard

Result: A thin strip appears on the right of the window.

Reproducible: Always
Comment 1 Siddhartha Dugar [:sdrocking] 2011-01-19 10:51:36 PST
Created attachment 505121 [details]
Screenshot for comparison
Comment 2 Ian Gilman [:iangilman] 2011-01-21 17:36:23 PST
Punting to the future.
Comment 3 Michael Yoshitaka Erlewine [:mitcho] 2011-01-21 22:17:44 PST
I believe the solution here is to set our overflow value on the body and/or #content to -moz-hidden-unscrollable:

https://developer.mozilla.org/en/CSS/-moz-hidden-unscrollable
Comment 4 Adam [:hobophobe] 2011-04-12 12:43:08 PDT
Created attachment 525475 [details] [diff] [review]
Solves line appearance issue by adding overflow: -moz-hidden-unscrollable to #content, as suggested by mitcho.
Comment 5 Ian Gilman [:iangilman] 2011-04-13 16:58:35 PDT
Comment on attachment 525475 [details] [diff] [review]
Solves line appearance issue by adding overflow: -moz-hidden-unscrollable to #content, as suggested by mitcho.

Thanks :)
Comment 6 Raymond Lee [:raymondlee] 2011-04-13 20:14:47 PDT
*** Bug 648995 has been marked as a duplicate of this bug. ***
Comment 7 Tim Taubert [:ttaubert] 2011-04-14 15:12:59 PDT
Hey Adam, it would be great to get this fix into the tree. Here is how to prepare the patch:

http://blog.bonardo.net/2010/06/22/so-youre-about-to-use-checkin-needed

Thank you!
Comment 8 Adam [:hobophobe] 2011-04-15 11:00:05 PDT
Created attachment 526309 [details] [diff] [review]
Same patch, but prepared for pushing.
Comment 9 :Ms2ger (⌚ UTC+1/+2) 2011-04-17 05:55:05 PDT
http://hg.mozilla.org/mozilla-central/rev/2befee093050
Comment 10 George Carstoiu 2011-06-29 08:09:04 PDT
Mozilla/5.0 (X11; Linux i686; rv:7.0a1) Gecko/20110629 Firefox/7.0a1

Verified issue on Ubuntu 11.04, Mac OS X 10.6, WinXP and Win 7. I was unable to reproduce issue -> setting status to Verified Fixed.

Note You need to log in before you can comment on or make changes to this bug.