Last Comment Bug 627215 - Post-FF4: Enable browser.sessionhistory.optimize_eviction
: Post-FF4: Enable browser.sessionhistory.optimize_eviction
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Document Navigation (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla6
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 610417
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-19 15:17 PST by Alon Zakai (:azakai)
Modified: 2011-04-30 10:33 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (6.98 KB, patch)
2011-04-11 11:38 PDT, Alon Zakai (:azakai)
no flags Details | Diff | Splinter Review
change pref to true (2.01 KB, patch)
2011-04-18 11:46 PDT, Alon Zakai (:azakai)
bugs: review+
Details | Diff | Splinter Review

Description Alon Zakai (:azakai) 2011-01-19 15:17:22 PST
Followup to bug 610417. We enabled the pref for Fennec, but left it off for Firefox to not risk regressions.

After FF4, we should enable this pref for Firefox, since it is beneficial (see details in previous bug, and TODO comments in the patch for that bug).
Comment 1 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-04-11 10:55:23 PDT
From the patch in bug 610417:
// NB: After 4.0, we should remove this option and the corresponding
//     pref - optimization should always be used

So I guess now that Firefox 4 has been released, this optimization should be used and the browser.sessionhistory.optimize_eviction pref should be removed?
Comment 2 Alon Zakai (:azakai) 2011-04-11 11:38:55 PDT
Created attachment 525119 [details] [diff] [review]
patch

Thanks for the reminder mw22!
Comment 3 Olli Pettay [:smaug] 2011-04-18 08:05:25 PDT
Comment on attachment 525119 [details] [diff] [review]
patch

Could we first flip the pref for desktop FF and after some time
remove this code.
Comment 4 Alon Zakai (:azakai) 2011-04-18 11:46:32 PDT
Created attachment 526775 [details] [diff] [review]
change pref to true

That does sound safer.

Btw, I don't know how these prefs update existing installations - will users that upgrade to this code get the pref changed? Or will it remain as it was set before (so they won't get the optimization)?
Comment 5 Alon Zakai (:azakai) 2011-04-29 17:13:14 PDT
http://hg.mozilla.org/mozilla-central/rev/17cbe366cd51
Comment 6 Jim Jeffery not reading bug-mail 1/2/11 2011-04-30 02:25:03 PDT
(In reply to comment #4)
> Created attachment 526775 [details] [diff] [review]
> change pref to true
> 
> That does sound safer.
> 
> Btw, I don't know how these prefs update existing installations - will users
> that upgrade to this code get the pref changed? Or will it remain as it was set
> before (so they won't get the optimization)?

I just installed the latest hourly build and checked before installing that the pref was 'false' - after the install to latest hourly/Nightly - the pref is now 'true' , so users will get the optimization without issue.
Comment 7 Alon Zakai (:azakai) 2011-04-30 10:33:22 PDT
Thanks Jim, good to know.

Note You need to log in before you can comment on or make changes to this bug.