Elements with opacity < 1 are not printed on OS X

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Florens Verschelde, Assigned: roc)

Tracking

({regression})

unspecified
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [softblocker], URL)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: 

On OS X 10.6.6 with Firefox 4b9, content with partial opacity (anything between 0 an 0.99999999) does not get printed. The areas were translucent content were are left blank. See the test case in the demo URL or the attached zip file.

Reproducible: Always

Steps to Reproduce:
From http://covertprestige.info/bugs/ff4-print-opacity/:

Test 1:
- "File > Print…"
- Hit "Preview" button. Launches the preview in Preview.app
- Print from Preview.app
Result: all text with opacity < 1.0 is not printed.

Test 2:
- "File > Print…"
- Hit "Print" button.
Result: all text with opacity < 1.0 is not printed.



I'm opening this bug as suggested in bug 262019 (from 2005, closed).
There's also bug 411699 which is similar to this, but reported for Windows and it reports that while Print Preview is broken, the actual printed page is ok. But in my experience on OS X, both Print Preview and actual printing are broken.
(Reporter)

Comment 1

7 years ago
Created attachment 505283 [details]
Simple testcase

One page tests opacity and the other tests color+rgba(). RGBA seems to work fine.
Regression range is http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a05e91710adb&tochange=c20f34eefa5d

roc, this looks like one of the things you pushed...
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
Keywords: regression
Component: Printing: Output → Graphics
QA Contact: printing → thebes
Assignee: nobody → roc
blocking2.0: ? → final+
Whiteboard: [softblocker]
Created attachment 506572 [details] [diff] [review]
fix

I missed this one in bug 624152, probably because I thought gfxQuartzPDFSurface would be used for printing, but it isn't!
Attachment #506572 - Flags: review?(jmuizelaar)
Whiteboard: [softblocker] → [softblocker][needs review]
Attachment #506572 - Flags: review?(jmuizelaar) → review+
Whiteboard: [softblocker][needs review] → [softblocker][needs landing]
http://hg.mozilla.org/mozilla-central/rev/4568082aec55
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Whiteboard: [softblocker][needs landing] → [softblocker]
You need to log in before you can comment on or make changes to this bug.