Closed Bug 627309 Opened 9 years ago Closed 9 years ago

Forward button wrongly clipped in RTL mode when using lightweight themes

Categories

(Firefox :: Theme, defect)

All
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 4.0b11
Tracking Status
blocking2.0 --- final+

People

(Reporter: mstange, Assigned: mstange)

References

Details

(Keywords: regression, rtl, Whiteboard: [hardblocker])

Attachments

(1 file, 1 obsolete file)

No description provided.
blocking2.0: --- → ?
Attached patch v1 (obsolete) — Splinter Review
Attachment #505381 - Flags: review?(dao)
Comment on attachment 505381 [details] [diff] [review]
v1

missed icons+text mode
Attachment #505381 - Attachment is obsolete: true
Attachment #505381 - Flags: review?(dao)
Attached patch v2Splinter Review
Attachment #505388 - Flags: review?(dao)
Keywords: regression
Summary: Forward button wrongly clipped when using lightweight themes → Forward button wrongly clipped in RTL mode when using lightweight themes
blocking2.0: ? → final+
Whiteboard: [hardblocker]
Attachment #505388 - Flags: review?(dao) → review+
http://hg.mozilla.org/mozilla-central/rev/8eb124d7bcc6
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b11
Could you please post some short description of what the problem was here for mere mortals like me?  :-)  Thanks!
Sure.
Bug 578422 added a mask to the forward button in lwtheme mode so that it doesn't extend under the (now transparent) round back button. However, this mask was assuming LTR orientation, so it was cutting out the circle shape on the wrong side in RTL mode (see attachment 50537 [details] [diff] [review]). Instead of creating another mask for the RTL case, I chose to flip the whole toolbarbutton using -moz-transform, so that the mask was flipped, too. The other changes in the patch were to unflip the untransformed button's shape and icon so that it doesn't get double-flipped.

Sorry, usually I'm the one who gets annoyed when people post insufficient bug descriptions...
Thanks a lot for your explanation, Markus!  I just want to keep an eye on what's happening in the RTL land because I'll soon start testing Persian builds... :-)
Duplicate of this bug: 629319
You need to log in before you can comment on or make changes to this bug.