Window unresponsive when resizing a browser window containing page that alerts on window.onresize.

RESOLVED DUPLICATE of bug 626963

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 626963
7 years ago
7 years ago

People

(Reporter: Mark Boas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b10pre) Gecko/20110119 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b10pre) Gecko/20110119 Firefox/4.0b10pre

The browser crashes when resized if JavaScript similar to :

window.onresize = function(event) {
    alert('mooo');
}

is used.

Reproducible: Always

Steps to Reproduce:
1.Go to http://happyworm.com/temp/ffox4/resizecrash2/
2.Press OK on the original alert
3.Resize browser
Actual Results:  
Browser crashes and freezes, leaving a white screen.

Expected Results:  
Mooo! should be alerted each time the browser is resized.
(Reporter)

Comment 1

7 years ago
OK I got carried away - mooo (not Mooo!) should be alerted each time the browser is resized. :)

Comment 2

7 years ago
It's not a Crash. The Browser Window is "opaque" (white screen). Also, if you have 2 windows open, the other one is still alive.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Crashes when resizing a browser window containing page that alerts on window.onresize. → Window unresponsive when resizing a browser window containing page that alerts on window.onresize.

Comment 3

7 years ago
This issue is not limited to mac os x, I have experienced this on windows 7 64.

It seems that cmd+r/f5 seems to bring the page back. Odd issue.

Maybe the alert overlay is not resizing with the browser, and going over the entire browser space?
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 626963
You need to log in before you can comment on or make changes to this bug.