Change the window focus !

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Olivier Pons, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)

I reproduced this bogue on 4 PCs at my work *under* Windows : XP, and Seven.
It only appears on Firefox.
Not on Chrome, not on Opera, not on Safari, and *not* on Firefox 3.6.13 / Ubuntu 10.04.


Reproducible: Always

Steps to Reproduce:
1. Open an empty tab, for example, go to google.com
2. Type CTRL-N to open a new window.
3. => The window focus changes whereas it shouldn't !

Actual Results:  
When the website appears, the windows focus changes.

Expected Results:  
When the website appears, the windows focus should stay on the same Window.

This bogue seems to be only under Windows and Firefox 3.6.13 (I've not tested with other versions).
Under Linux it seems to work as expected.
(Reporter)

Comment 1

8 years ago
Sorry typo :

Steps to Reproduce:
1. Open an empty tab, for example, go to google.com
2. Type CTRL-N to open a new window.
3. go to http://soyezsur.fr/
4. => The window focus changes whereas it shouldn't !
Please test it again with Firefox 4.0beta9.

Comment 3

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.14pre) Gecko/20110120 Namoroka/3.6.14pre

Confirmed on latest 3.6.14pre nightly build. The window focus changes to the previous window instead of the currect window when opening the site http://soyezsur.fr/

Works fine in 
Mozilla/5.0 (Windows NT 6.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110120 Firefox/4.0b10pre

Updated

8 years ago
Version: unspecified → 3.6 Branch

Comment 4

7 years ago
Reporter -> Are you still experiencing this issue with the latest version of Firefox 5?
(Reporter)

Comment 5

7 years ago
No code change on http://soyezsur.fr/
It seems it's gone:
- No problem on Chrome 10.0.648.204
- No problem on Firefox 5.0
- No problem on Opera 11.11
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.