mozilla crashes on start-up

RESOLVED WORKSFORME

Status

P3
critical
RESOLVED WORKSFORME
18 years ago
14 years ago

People

(Reporter: gtr, Assigned: asa)

Tracking

({crash})

Trunk
Sun
Solaris
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; SunOS 5.8 sun4u)
BuildID:    20001211

It just dumps core when trying to start up, before opening its first window. 
Wierd: it worked OK last night!

Reproducible: Always
Steps to Reproduce:
1. cd to directory where mozilla is installed 
(<local path>/mozilla/package)
2. mozilla &


Actual Results:  
MOZILLA_FIVE_HOME=.
 
LD_LIBRARY_PATH=.:/data/patt/ftools/lheasoft/SunOS_5.6_sparc/lib:/usr/lib:/opt/X11R6/lib:/usr/local/lib:/usr/openwin/lib:/usr/ucblib:/opt/SUNWspro/lib
     LIBRARY_PATH=.:./components
       SHLIB_PATH=.
          LIBPATH=.
       ADDON_PATH=.
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=

Gdk-WARNING **: shmat failed!

gtr@cass111> Registering plugin 0 for: "*","All types",".*"
Segmentation Fault - core dumped


No windows open at that point.

Gdk-WARNING **: shmat failed!

gtr@cass111> Registering plugin 0 for: "*","All types",".*"
Segmentation Fault - core dumped

[3]    Exit 139                      mozilla


Expected Results:  Browser opens.

I ran the core through SUN Workshop's debugger.  Here's the stack trace:

   main(0x0, 0xffbee5dc, 0xffbee5e4, 0x371b0, 0x0, 0x0)
   0x16e60(0x0, 0xff2cf890, 0x0, 0x5, 0x100d4, 0x0)
   0x15784(0xe44e8, 0x1, 0x3b920, 0xfe01d460, 0x3f8, 0x1)
   0x15548(0x0, 0x91158, 0x1, 0x0, 0x0, 0xffe)
   EnumerateChildren__6nsPrefPCcPFPCcPv_vPv(0x6, 0x24300,
 0x152c8, 0xffbee2e0, 0xfdc5e09c, 0x0)
   0x1538c(0xbecb0, 0xffbee2e0, 0x6, 0x0, 0x0, 0xfece1c90)
   0x14e3c(0x0, 0xffffffff, 0xffffffff, 0xbecc0, 0xff3e260c,
 0xffbee1e9)
   GetDefaultArgs__23nsBrowserContentHandlerPPUs(0x0,
 0xffbee05c, 0x182db4, 0xfc6ae270, 0x81010100, 0xff00)
   
assign_from_helper__13nsCOMPtr_baseRC15nsCOMPtr_helperRC4nsID
(0xffbedfa0, 0xffbedfa8, 0xfc6c7224, 0xfc64b78c, 0x81010100,
 0xff00)
   __cl__C17nsGetServiceByCIDRC4nsIDPPv(0xffbedfa8,
 0xfc6c7224, 0xffbeddcc, 0xff2126a8, 0xffbee120, 0xffbee157)
   
GetService__16nsServiceManagerRC4nsIDT1PP11nsISupportsP19nsIShutdownListener
(0xfc6b61c8, 0xfc6c7224, 0xffbeddcc, 0x0, 0xff3e260c,
 0xfd180018)
   
GetService__20nsServiceManagerImplRC4nsIDT1PP11nsISupportsP19nsIShutdownListener
(0x381e8, 0xfc6b61c8, 0xfc6c7224, 0xffbeddcc, 0x0, 0xff212ed0)

0xfc6b61c8, 0x0, 0xfc6c7224, 0xffbedc48, 0x297ec, 0xff3bcfd0)
   
CreateInstance__22nsComponentManagerImplRC4nsIDP11nsISupportsT1PPv
(0x3a648, 0xfc6b61c8, 0x0, 0xfc6c7224, 0xffbedc48, 0xff20a4b0)
   CreateInstance__16nsGenericFactoryP11nsISupportsRC4nsIDPPv
(0x182e70, 0x0, 0xfc6c7224, 0xffbedc48, 0xff20cc90, 0x0)
   0xfc61b1f8(0x80004005, 0xfc6c7224, 0xffbedc48, 0xfc61b154,
 0xffbedb5c, 0xff20d6f8)
   Release__15nsGlobalHistory(0x95cb8, 0xfc62e27c, 0x0,
 0xff21ed3c, 0xffbed658, 0xffbed654)
   _15nsGlobalHistory(0x95cb8, 0x3, 0xfc62df0c, 0xfd95520c,
 0x0, 0x0)
   CloseDB__15nsGlobalHistory(0x95cb8, 0x95cc8, 0xbc8a0,
 0xfd95534c, 0xff20cc90, 0xff212ed0)
   ExpireEntries__15nsGlobalHistoryi(0x95cb8, 0x0, 0x183098,
 0x18f938, 0x1861b0, 0xfc5b7d88)

Comment 1

18 years ago
Try to load mozilla without the plugins, i.e. remove the java and flash plugins 
from the plugins directory. Tell us if this did the trick. :)
Fabian.
(Reporter)

Comment 2

18 years ago
I'm not sure that I _have_ Java and flash plugins.  The plugins directory
extracted from the tarfile contains only libnullplugin.so. I tried deleting that
and then mozilla started normally, once.  To confirm, I restored everything from
the tarfile and it crashed next time I started it.  So I deleted
libnullplugin.so again and this time it still crashed on start-up.
reporter, have you tried a clean install of Mozilla with a new profile?
*** Bug 62741 has been marked as a duplicate of this bug. ***
Was the build used 2000-12-11-*21* ?  If so, it may be the problem caused in
that build only by the fix for bug 55293.
(Reporter)

Comment 6

18 years ago
I tried deleting everything in .mozilla and restarting.  Same crash, so far as I
can see.  Regarding the exact build number, yes it could well have been
2000-12-11-21, but how do I find that out if I can't start the programme?  I
can't see the build number anywhere obvious in the installed s/w. "strings
mozilla-bin | grep 2000" doesn't find anything.  Would it be possible for you to
lob a little text file into future builds stating the build number? 

Comment 7

18 years ago
If you don't see a build id it's probably 0.6 branch,
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-sparc-sun-solaris2.6.tar.gz
should be trunk for a while.
Keywords: crash

Comment 8

18 years ago
This is starting to look serious, three people on solaris reported this.
Someone busted Solaris?

Comment 9

18 years ago
*** Bug 60350 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
this *could* be related to ultrasparc-only code that we're compiling... is
anyone who is seeing this seeing it on unltrasparc, or just sparc?

Comment 11

18 years ago
I'm seeing it on an Ultra 10, sun4u architecture.  Kernel jumbo patch 105181-22.
(Reporter)

Comment 12

18 years ago
I see the crash on an Ultra 5:
SunOS cass111 5.8 Generic_108528-03 sun4u sparc SUNW,Ultra-5_10

Comment 13

18 years ago
*** Bug 62805 has been marked as a duplicate of this bug. ***

Comment 14

18 years ago
Umm.. sorry to poke my nose in.. but this is still labeled UNCONFIRMED ... 
seeing as other bugs are marked as dupes.. I think that confirms it.
Marking as New.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 15

18 years ago
Crash is confirmed on Sun Ultra 1.

Crash with SEGV is NOT confirmed on sun4m architecture, as the programme won't
run there at all! mozilla-bin is reported by the file utility as

mozilla-bin:    ELF 32-bit MSB executable SPARC32PLUS Version 1, V8+ Required,
dynamically linked, stripped

and (IIRC) SPARC instruction set V8+ is only available on sun4u.  This is a
problem in its own right, as Solaris sites tend to have lots of sun4m machines
still in service.

Comment 16

18 years ago
I also see this bug, and I am running:
Mozilla/5.0 (X11; U; SunOS 5.7 sun4u; en-US; m18) Gecko/2000121121
I have no plugins.  I'm running on an Ultra-60.
My mozilla doesn't always crash however.  However, once it does crash, I can't
get it to run again unless I run an older build first.  When it crashes it
leaves the same stack trace as the one listed by the original reporter.  Ending in:
#0  0xfc0329f4 in nsGlobalHistory::ExpireEntries ()
#1  0xfc032e58 in nsGlobalHistory::CloseDB ()
#2  0xfc02df9c in nsGlobalHistory::~nsGlobalHistory
...etc...

I also have a cleaner startup:
./run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=.

LD_LIBRARY_PATH=.:/usr/dt/lib:/usr/openwin/lib:/usr/openwin/lib:/usr/lib:/usr/local/lib
     LIBRARY_PATH=.:./components
       SHLIB_PATH=.
          LIBPATH=.
       ADDON_PATH=.
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
Registering plugin 0 for: "*","All types",".*"
Segmentation Fault - core dumped

Comment 17

18 years ago
cc people who might know about sparcs.

If this is a build issue, please send to build config. Thanks
Whiteboard: Leaf suspects the target instruction set is unavailable

Comment 18

18 years ago
my theory is obviously not it, if people are seeing a crash on ultrasparc.
Whiteboard: Leaf suspects the target instruction set is unavailable
(Reporter)

Comment 19

18 years ago
The problem has gone away in build 2000121421.

Comment 20

18 years ago
Just tried the 2000/12/19 nightly build and I get the same problem
as I reported in bug <a
href="http://bugzilla.mozilla.org/show_bug.cgi?id=62805">62805</a>.
Which is not exactly a crash. I don't recall if I tried the 2000/12/14 nightly
build or not but I have tried yesterday and todays build and the problem was the
same.
 

Comment 21

18 years ago
Is anyone on solaris still seeing this? Chris Lusena, you might consider 
re-opening your bug, since the symptoms are not the same (didn't crash at the 
same place).
However if you can no longer reproduce, leave it as a dup.
Thank you!

Comment 22

18 years ago
The latest builds of mozilla (as well as build 2000121421) are working for me
(SunOS 5.6 on UltraSPARC II).  Thanks so much developers!!

Comment 23

18 years ago
can we get one more confirmation before we resolve this bug?

Comment 24

18 years ago
Just got back from vaction and tried the 20001231 build it now works for me.
(Assignee)

Comment 25

18 years ago
excellent.  marking wfm
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.