Firefox incorrectly reports "The page isn't redirecting properly"

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Kevin Gainer, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

When trying to access this URL, Firefox reports "The page isn't redirecting properly" and will not load the page.  IE loads it just fine.

Reproducible: Always

Steps to Reproduce:
1. Enter  "http://www.washingtontimes.com/news/2011/jan/19/on-the-day-roe-dies/?page=2"  in the address bar.
2. Press ENTER.
3.
Actual Results:  
Firefox says: "Firefox has detected that the server is redirecting the request for this address in a way that will never complete."

Expected Results:  
Page loads.

I have cookies & javascript fully enabled for this site.  All of its pages & next-page links (that I have tried) load OK except for this one.

(The problematic URL is from the next-page link found on this page:  http://www.washingtontimes.com/news/2011/jan/19/on-the-day-roe-dies/ )
That usually happens only if you have a cookie problem for this site.
Do you get the same problem with a new profile http://support.mozilla.com/en-US/kb/Managing+profiles ?

Updated

7 years ago
Version: unspecified → 3.6 Branch

Comment 2

7 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.14pre) Gecko/20110120 Namoroka/3.6.14pre

Works for me.
(Reporter)

Comment 3

7 years ago
OK, I've checked and the link works fine with a new profile, or with the same version of Firefox on a different computer.

So I tried deleting the 2 cookies I had for that site in the original profile and the problem is gone.

Thanks, guys.

I'd never imagined that a bad cookie could have such a specific effect, which was why I thought there was a bug in Firefox.  Can you tell me why only the one link was affected?
It's an bug in the page but it's no unique case. The page should remove/rewrite their own cookie if it doesn't like the content. but it sends you instead in a redirection loop.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.