Closed Bug 627407 Opened 9 years ago Closed 9 years ago

Update Firefox 4 Beta Homepage for RC

Categories

(www.mozilla.org :: General, defect, critical)

defect
Not set
critical

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: lmesa, Assigned: rik)

References

()

Details

(Whiteboard: [FxRC])

Attachments

(7 files, 2 obsolete files)

This page needs:
-updated logo 
-download button
-updated copy
-updated feedback screenshot
-updated legal policy

Will upload materials as available.
Blocks: 627056
(In reply to comment #0)
> This page needs:
> -updated logo 
> -download button
> -updated copy
> -updated feedback screenshot
> -updated legal policy
> 
> Will upload materials as available.

We also need to change URL to: http://www.mozilla.com/firefox/RC/
Attached file Firefox 4 RC Logo
Comment on attachment 506439 [details]
The updated Submit Feedback Screenshot should look like this

please ignore this attachment. need to upload the proper version of this screenshot.
Attachment #506439 - Attachment is obsolete: true
Depends on: 628416
Attached file Updated Copy for Beta (RC) Page (obsolete) —
Copy changes in Red
Whiteboard: [FxRC]
Target Milestone: --- → 1.3
Assignee: nobody → jlong
Hey Laura,

I'll get to work on this one. Should the /firefox/beta page redirect here or just they exist separately?
Laura, I don't have illustrator to open the AI files. Can we get them posted as PNGs in the resolution you want them at?
(In reply to comment #7)
> Hey Laura,
> 
> I'll get to work on this one. Should the /firefox/beta page redirect here or
> just they exist separately?

It should probably redirect here, thanks!(In reply to comment #8)
> Laura, I don't have illustrator to open the AI files. Can we get them posted as
> PNGs in the resolution you want them at?

I can try! Coming shortly!
Attached image RC Logo PNG
How's this?
T(In reply to comment #10)
> Created attachment 511399 [details]
> RC Logo PNG
> 
> How's this?

That should be fine, thanks! Also, the download button attachment is messed up, it doesn't have a file format. What is it? An AI file?
(In reply to comment #10)
> How's this?

Laura, sorry, I hadn't looked at the site when I said it's ok. Can you give me the logo with a transparent background? It's sitting on a blue background that might have some gradient.
(In reply to comment #2)
> Created attachment 506433 [details]
> Firefox 4 RC Download Button

I need this button without the "free download" text, like this:

http://www.mozilla.com/img/firefox/beta/4/download-button.png

also, make sure the file has an extension
Depends on: 633323
Status: NEW → ASSIGNED
The copy changes do not include this, but the "Install the Beta" text should probably be changed to "Install the RC".
Actually, there were several places where Beta was mentioned throughout the page, and I've tried to change all of them. Please look through this page:

https://www-trunk.stage.mozilla.com/en-US/firefox/RC/

Still trying to get the CDN updated so the new logo shows.
Attached image Product bar
So, the legalese will also be changing--waiting on 627419 before we have that copy. 

Only other place i saw beta was in the products bar on the top right.
Also, james--

I think we can completely remove the legalese box under steps 1, 2, 3. 

Its no longer relevant because RC no longer has the feedback add-on. 

Thanks!
Attached image logo looks weird
This is the only thing i see that's weird on the site.
Steven was revamping the header and he's still working on it. Not sure what the bug is for it though.
Firefox 4 Beta includes an updated interface for all platforms that’s sleeker
and easier to use.

should be updated to

Firefox 4 RC includes an updated interface for all platforms that’s sleeker and
easier to use.



The link on the right had side  next to Products should also be updated to
Firefox 4 RC
Duplicate of this bug: 634056
From Raymond:

Firefox 4 Beta includes an updated interface for all platforms that’s sleeker
and easier to use.

should be updated to

Firefox 4 RC includes an updated interface for all platforms that’s sleeker and
easier to use.



The link on the right had side  next to Products should also be updated to
Firefox 4 RC
Depends on: 634053
+1
Regarding the previous comments, those actually apply to the features page which is bug 627433. I wouldn't worry about testing all the Beta -> RC copy changes until we are finished updating all the copy, since every bug includes globally changing beta -> rc.
(In reply to comment #7)
> Hey Laura,
> 
> I'll get to work on this one. Should the /firefox/beta page redirect here or
> just they exist separately?

- hey james. eventually /firefox/beta  should redirect to /firefox/RC. However, because we still have beta 12 before RC, we cant have it redirect yet and will need to exist separately until RC.
When the RC goes out you still want to serve beta 12? I would think you want people to be using RC.

I've already implemented all the redirects and overwrite images. This is definitely reversable, but it'll be a good bit more work to have both co-exist.
after rc goes out we want to redirect /firefox/beta  to /firefox/RC.

but they need to co-exist at this time (until rc is released) as we still have beta 12 coming up.
Ok, I see. I'll revert the changes on trunk and maybe push them to the ff4 branch.
Target Milestone: 1.3 → 1.4
Hi James. 
Sorry I just noticed this now. But the copy is actually different from the copy I attached back in Feb. 8. It still mentions the Feedback Add-ons. 

http://www-trunk.stage.mozilla.com/en-US/firefox/RC/

Under the Install the RC box it currently says:
The Firefox 4 RC includes the Feedback Add-on which includes you in user studies. No data will be sent to Mozilla without your permission. More information

It should be:
Install the Firefox 4 Release Candidate (RC)
[Firefox  RC Logo]
Firefox 4 is almost here. Be the first one to check it out. 

Under the Give us Feedback box it says:
Click the Feedback button at any time to tell us what you think. Read more about Test Pilot.

It should be: 
You can now give us feedback on the RC. Just go to the Help menu and click the submit feedback option at any time to tell us what you think.

Please delete current copy (see below) in the Spread the Word
Help us make Firefox 4 RC even better. After installing, click on feedback button to tell us what you think!. 

I am attaching a new doc for the most updated copy. 

Thanks!
Attached file RC Home Copy 2.22.2011
Attachment #510538 - Attachment is obsolete: true
Ok, it's done:

http://rc.moz.jlongster.com/en-US/firefox/RC/

One thing I'm not sure about is the Firefox RC Logo. Are you talking about the one in the upper left of the page? Isn't is redundant to also include it in the "Install the RC" box?
(In reply to comment #32)
> Ok, it's done:
> 
> http://rc.moz.jlongster.com/en-US/firefox/RC/

This looks awesome. 


> 
> One thing I'm not sure about is the Firefox RC Logo. Are you talking about the
> one in the upper left of the page? Isn't is redundant to also include it in the
> "Install the RC" box?


I think it looks awesome the way it is.
please update copy on the right top corner of the page 

Products/Firefox4RC
features
technology
feedback
Feedback privacy policy  to just Privacy Policy 
faq
press kit
Also, we should make sure www.mozilla.com/firefox/beta,
www.mozilla.com/firefox/RC and www.mozilla.com/firefox/rc redirect to this page. 

Both RC and rc should work.
Assignee: jlong → anthony
hi anthony. reviewed the page. it looks good. can you please confirm that comment 35 is also good to go?
Some errors and trials in r83837, r83838, r83839. But now, all /rc/ links redirect to the /RC/ version.

And so I guess this fixes that bug.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Keywords: qawanted
Resolution: --- → FIXED
Small bug found:



"Step 3 ("Spread the word") seems a little odd -- the 2nd textbox says "Customize your Firefox 4 RC tweet!", but it appears that's actually for Facebook? (especially since the textbox above is obviously for Twitter and is editable) "

The box above Facebook should just say "Customize your Firefox 4 RC sharing message!"
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I think I left off a few revisions for this bug. So here are all the revisions in trunk for this bug. These bugs also implement the redirection of the beta links to RC.

r82441, r82472, r82473, r82481, r82604, r83160, r83837, r83838, r83839 on trunk
(In reply to comment #39)
> The box above Facebook should just say "Customize your Firefox 4 RC sharing
> message!"

done in r84380 on trunk, marking resolved
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
merged everything into stage on r84386
Attached image screenshot
button is broken in IE6-IE8
committed fix for facebook button in trunk r84392
Raymond, in my VM the clicking the facebook button in IE8 doesn't do anything. Can you see if it works for you?
Status: RESOLVED → REOPENED
Keywords: qawanted
Resolution: FIXED → ---
(In reply to comment #45)
> Raymond, in my VM the clicking the facebook button in IE8 doesn't do anything.
> Can you see if it works for you?

the facebook share button works for me in IE8 but not in IE6
hi james and raymond. any updates on this? are we going to be okay if we launch rc tomorrow? thanks
Can someone confirm please? Pages being shipped today.
Severity: normal → critical
I'm going through all the bugs right now and gathering them together to be rolled out.

This process would be incredibly easy in Git, and would only take a few seconds. Instead I'm having to hunt down all the SVN revisions attached to the RC bugs. I'm going to talk about switching mozilla.com to Git during the work week, as I think it's desperately needed.
Raymon(In reply to comment #46)
> the facebook share button works for me in IE8 but not in IE6

button works fine for me in IE6. Can you test it on a couple different machines?
The share this button link doesn't work
fixed in trunk r84467
The RC redirects are case-sensitive, so I've committed a fix to make mozilla.com/rc work as well as /RC

in trunk r84468
pushed the above two revisions to stage r84469
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
verified fixed http://www.mozilla.com/en-US/firefox/RC/
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.