Update Firefox 4 Feedback Page for RC

VERIFIED FIXED in 1.4

Status

defect
--
critical
VERIFIED FIXED
9 years ago
7 years ago

People

(Reporter: gjimenez, Assigned: jlong)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [FxRC], )

Attachments

(5 attachments, 1 obsolete attachment)

This page needs:
-updated logo 
-updated copy
-updated feedback screenshot

Will upload materials as available.
Blocks: 627056
Posted file RC Logo
Please update logo on this page with attached version.
Depends on: 625165
(In reply to comment #0)
> This page needs:
> -updated logo 
> -updated copy
> -updated feedback screenshot
> 
> Will upload materials as available.

We also need to update the URL to: http://www.mozilla.com/firefox/RC/feedback/
Comment on attachment 506437 [details]
The updated Submit Feedback Screenshot should look like this

please ignore this attachment. need to upload the proper version of this screenshot.
Attachment #506437 - Attachment is obsolete: true
Depends on: 628416
Pretty minor copy changes. 
Changes are in red. 
Plus new link for filing a Firefox 4 RC bug in 2nd section ("developers: we need you")
Whiteboard: [FxRC]
Target Milestone: --- → 1.3
Assignee: nobody → anthony
Target Milestone: 1.3 → 1.4
Committed r82998 visible on http://www-trunk.stage.mozilla.com/en-US/firefox/RC/feedback/
Status: NEW → RESOLVED
Closed: 9 years ago
Keywords: qawanted
Resolution: --- → FIXED
Target Milestone: 1.4 → 1.3
This needs to be tagged 1.4 but go out whenever the RC comes out.
Moving to 1.4 until I can talk to Rik about this. Pushing all of 1.3 out today though.
Target Milestone: 1.3 → 1.4
reopening as this does not validate http://html5.validator.nu/?doc=http://www-trunk.stage.mozilla.com/en-US/firefox/RC/feedback/
Status: RESOLVED → REOPENED
Keywords: qawanted
Resolution: FIXED → ---
Depends on: 636182
please update copy on the right top corner of the page 

Products/Firefox4RC
features
technology
feedback
Feedback privacy policy  to just Privacy Policy 
faq
press kit
Committed r83435.

This fixes the validation errors except one that I don't understand. Should be
ok to launch though.
Committed r83436.

This updates the copy for the navigation menu in the right top corner.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Keywords: qawanted
Resolution: --- → FIXED
Posted image screenshot
page does not validate and throws a js error in IE6 see attached screenshot
Status: RESOLVED → REOPENED
Keywords: qawanted
Resolution: FIXED → ---
For the validation error, I've confirmed with MikeSmith that it is a validator bug:
"I fixed that bug a while back. fix is in the repo but validator.nu hasn't been redeployed yet after I made that change"

For the JS error, see bug 626639.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Posted image screenshot
page is broken in IE 6. See attached screenshot
Committed r83969.

This fixes the JS errors and the IE6 bug.
Keywords: qawanted
Committed r83971. Got rid of "Beta" in the page title.
Looks good!
Posted image newShot
still broken
hi anthony. per bug 636182. let's remove the poll and see if the page works after removing the poll. thanks.
The poll is already removed but we still have a small bug with IE6 as said in comment 20.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee: anthony → jlong
Severity: normal → critical
Ok, I've tracked down the problem. The bug in comment 20 does not happen when the page loads, but it happens when the user hovers over the nav (and the nav menu appears).

So this is a bug in the nav implementation; somewhere it's messing up the layout.
Depends on: 639594
Steven, Anthony--can you help?
I'm digging into this now to see if it looks easy or not.
r84356 and r84358 pushed to trunk for this bug.

The former is Steven's fix for the collapsing issue in IE6, the latter is a few tweaks to make the signup form look better in IE6.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Keywords: qawanted
Resolution: --- → FIXED
merged all revisions from trunk to staging in r84397
(In reply to comment #29)
> qa-verified-stage
> http://www.stage.mozilla.com/en-US/firefox/RC/feedback/index.html

hey raymond- the feedback screenshot on this page is wrong. 

it looks fine on this one: [reply] [-] Description Grace 2011-01-20 10:30:24 PST

This page needs:
-updated logo 
-updated copy
-updated feedback screenshot

Will upload materials as available.

[reply] [-] Comment 1 Laura Mesa 2011-01-24 07:49:03 PST

Created attachment 506401 [details]
RC Logo

Please update logo on this page with attached version.

[reply] [-] Comment 2 Grace 2011-01-24 09:41:27 PST

Created attachment 506437 [details]
The updated Submit Feedback Screenshot should look like this

[reply] [-] Comment 3 Grace 2011-01-24 09:47:14 PST

(In reply to comment #0)
> This page needs:
> -updated logo 
> -updated copy
> -updated feedback screenshot
> 
> Will upload materials as available.

We also need to update the URL to: http://www.mozilla.com/firefox/RC/feedback/

[reply] [-] Comment 4 Grace 2011-01-24 14:15:02 PST

Comment on attachment 506437 [details]
The updated Submit Feedback Screenshot should look like this

please ignore this attachment. need to upload the proper version of this
screenshot.

[reply] [-] Comment 5 Grace 2011-02-08 00:17:56 PST

Created attachment 510528 [details]
Updated Copy for Feedback Page

Pretty minor copy changes. 
Changes are in red. 
Plus new link for filing a Firefox 4 RC bug in 2nd section ("developers: we
need you")

[reply] [-] Comment 6 Anthony Ricaud (:rik) 2011-02-21 08:39:42 PST

Committed r82998 visible on
http://www-trunk.stage.mozilla.com/en-US/firefox/RC/feedback/

[reply] [-] Comment 7 James Long 2011-02-22 08:44:45 PST

This needs to be tagged 1.4 but go out whenever the RC comes out.

[reply] [-] Comment 8 James Long 2011-02-22 09:36:54 PST

Moving to 1.4 until I can talk to Rik about this. Pushing all of 1.3 out today
though.

[reply] [-] Comment 9 raymond [:retornam] 2011-02-22 15:20:44 PST

reopening as this does not validate
http://html5.validator.nu/?doc=http://www-trunk.stage.mozilla.com/en-US/firefox/RC/feedback/

[reply] [-] Comment 10 Grace 2011-02-26 14:21:57 PST

please update copy on the right top corner of the page 

Products/Firefox4RC
features
technology
feedback
Feedback privacy policy  to just Privacy Policy 
faq
press kit

[reply] [-] Comment 11 Laura Mesa 2011-02-28 09:48:53 PST

http://www.mozilla.com/en-US/firefox/beta/feedback/ and
http://www.mozilla.com/en-US/firefox/RC/feedback/ should redirect to 
http://www.mozilla.com/en-US/firefox/rc/feedback/.

[reply] [-] Comment 12 Anthony Ricaud (:rik) 2011-02-28 11:36:08 PST

Committed r83435.

This fixes the validation errors except one that I don't understand. Should be
ok to launch though.

[reply] [-] Comment 13 Anthony Ricaud (:rik) 2011-02-28 11:51:25 PST

Committed r83436.

This updates the copy for the navigation menu in the right top corner.

[reply] [-] Comment 14 raymond [:retornam] 2011-02-28 13:32:01 PST

Created attachment 515726 [details]
screenshot

page does not validate and throws a js error in IE6 see attached screenshot

[reply] [-] Comment 15 Anthony Ricaud (:rik) 2011-03-01 03:19:07 PST

For the validation error, I've confirmed with MikeSmith that it is a validator
bug:
"I fixed that bug a while back. fix is in the repo but validator.nu hasn't been
redeployed yet after I made that change"

For the JS error, see bug 626639.

[reply] [-] Comment 16 raymond [:retornam] 2011-03-02 10:42:42 PST

Created attachment 516304 [details]
screenshot

page is broken in IE 6. See attached screenshot

[reply] [-] Comment 17 Anthony Ricaud (:rik) 2011-03-04 09:51:45 PST

Committed r83969.

This fixes the JS errors and the IE6 bug.

[reply] [-] Comment 18 Anthony Ricaud (:rik) 2011-03-04 10:06:34 PST

Committed r83971. Got rid of "Beta" in the page title.

[reply] [-] Comment 19 Laura Mesa 2011-03-04 10:10:18 PST

Looks good!

[reply] [-] Comment 20 raymond [:retornam] 2011-03-04 14:35:49 PST

Created attachment 517008 [details]
newShot

still broken

[reply] [-] Comment 21 Grace 2011-03-07 00:23:15 PST

hi anthony. per bug 636182. let's remove the poll and see if the page works
after removing the poll. thanks.

[reply] [-] Comment 22 Anthony Ricaud (:rik) 2011-03-07 07:45:19 PST

The poll is already removed but we still have a small bug with IE6 as said in
comment 20.

[reply] [-] Comment 23 James Long 2011-03-07 13:16:14 PST

Ok, I've tracked down the problem. The bug in comment 20 does not happen when
the page loads, but it happens when the user hovers over the nav (and the nav
menu appears).

So this is a bug in the nav implementation; somewhere it's messing up the
layout.

[reply] [-] Comment 24 Laura Mesa 2011-03-07 18:01:13 PST

Steven, Anthony--can you help?

[reply] [-] Comment 25 James Long 2011-03-08 07:54:05 PST

I'm digging into this now to see if it looks easy or not.

[reply] [-] Comment 26 James Long 2011-03-08 08:52:25 PST

r84356 and r84358 pushed to trunk for this bug.

The former is Steven's fix for the collapsing issue in IE6, the latter is a few
tweaks to make the signup form look better in IE6.

[reply] [-] Comment 27 raymond [:retornam] 2011-03-08 09:05:53 PST

qa-verified-trunk http://www-trunk.stage.mozilla.com/en-US/firefox/RC/feedback/

[reply] [-] Comment 28 James Long 2011-03-08 14:19:45 PST

merged all revisions from trunk to staging in r84397

[reply] [-] Comment 29 raymond [:retornam] 2011-03-08 14:21:50 PST

qa-verified-stage
http://www.stage.mozilla.com/en-US/firefox/RC/feedback/index.html
(In reply to comment #29)
> qa-verified-stage
> http://www.stage.mozilla.com/en-US/firefox/RC/feedback/index.html

the feedback screen shot on this one is the correct screenshot. 

screenshot looks fine on this one: http://www-trunk.stage.mozilla.com/en-US/firefox/RC/feedback/
(In reply to comment #31)
> (In reply to comment #29)
> > qa-verified-stage
> > http://www.stage.mozilla.com/en-US/firefox/RC/feedback/index.html
> 
> the feedback screen shot on this one is the correct screenshot. 
> 
> screenshot looks fine on this one:
> http://www-trunk.stage.mozilla.com/en-US/firefox/RC/feedback/

Agreed. I think this is still resolved.
Some of these bugs are really hard to roll out because it's not clear what revisions need to get pushed. I'll double check that all the changes got pushed.
Found it. bug 628416 has a change that needed to be pushed.
pushed r84443 to staging
Component: www.mozilla.org/firefox → www.mozilla.org
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.