Add the ability to specify identifiers for blocklist items, which will be appended to the "learn more" url

RESOLVED DUPLICATE of bug 406026

Status

()

Toolkit
Add-ons Manager
--
enhancement
RESOLVED DUPLICATE of bug 406026
7 years ago
7 years ago

People

(Reporter: christian, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
We should add the ability to specify identifiers for blocklist items, which will be appended to the "learn more / why did we block this" url.

Currently when we block add-ons we point to http://www.mozilla.com/blocklist/ where we have a list of everything we have ever blocked. This is lame and doesn't tell the user much.

We should be able to add a unique identifier to a blocklist entry and those should be added to the query string of the URL. That way, on the server we can only show relevant entries and can perhaps have more user-friendly text than 1 sentence plus bug numbers for each entry.
We could also just append the GUID of the block as a parameter and when this info page is moved to AMO, AMO would return the right information.
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> We could also just append the GUID of the block as a parameter and when this
> info page is moved to AMO, AMO would return the right information.

But we way block different ranges of the same GUID for different FF versions, right?
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 406026
You need to log in before you can comment on or make changes to this bug.