Status

()

Firefox
General
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: tom brinkman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/534.3 (KHTML, like Gecko) Ubuntu/10.10 Chromium/6.0.472.63 Chrome/6.0.472.63 Safari/534.3
Build Identifier: 

I'm not able to download the javascript test library.

See: http://www.mozilla.org/js/tests/library.html

See the section towards the bottom of this web page,
which is titled: How do I run the JavaScript tests?

I just need the link to download the Javascript tests.  



Reproducible: Always
Which link exactly are you referring to?
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Which link exactly are you referring to?

From Web page:
http://www.mozilla.org/js/tests/library.html

<start>
First, retrieve the mozilla/js/tests directory. You can download this from ftp.mozilla.org or one of the mirrors in a file called pub/js/js-tests-<date-stamp>.tar.gz, or you can check it out directly from cvs If you have a complete Mozilla source tree, change to the mozilla/js directory, and issue the command cvs up -d tests to retrieve the tests directory from cvs.
<end>

None of this works for me.  It looks like its really old, does not match current environment.

I just need the javascript tests framework.

File: js-tests-<date-stamp>.tar.gz
The link to the tests. The directory on the ftp ( ftp://ftp.mozilla.org/pub/mozilla.org/js/) doesn't contain tests as far as i can see and we don't use cvs anymore but they are still available if you checkout the tree using hg and there are files labeled with test here ftp://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-central/
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.