Sync setup settings ignored at next launch

RESOLVED WORKSFORME

Status

Cloud Services
Firefox Sync: Backend
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Jonathan M. Lane, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b10pre) Gecko/20110120 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b10pre) Gecko/20110120 Firefox/4.0b10pre

Upon switching to Firefox 4.0b7 for testing, I noticed that sync stopped working now that Firefox is using the built-in sync. In both the Tools menu and the Preferences -> Sync tab, I am prompted to "Set Up (Firefox) Sync" upon each restart of Firefox. I can confirm that my sync settings are correct, since I can finalize the setup wizard and force multiple syncs as long as I do not quit Firefox. As soon as Firefox quits (normal quit process, not crashing out), upon restarting, Firefox will not acknowledge that my sync settings are currently saved in my prefs.js file! I confirmed that the settings were indeed there after quit and upon relaunch (about:config and prefs.js show this). If I start the Sync Setup wizard again, my sync settings are cleared out at that point.

Reproducible: Always

Steps to Reproduce:
1. Launch Firefox and start the Sync Setup wizard by clicking Tools -> Set Up Sync... or going into Preferences -> Sync tab, clicking "Set Up Firefox Sync".
2. Connect to my Firefox Sync account when prompted by the wizard, providing the username, password, and sync key (all valid) on the following screen.
3. Sync Complete screen is shown, click done, and force a sync by clicking Tools -> Sync.
4. Check about:config for key "services.sync.lastSync" with the current date-time.
5. Check my profile prefs.js file's last modified time and make a note of it.
5. Quit Firefox using File -> Quit.
6. Launch Firefox and check about:config for "services.sync" keys with my account details.
7. Check my profile prefs.js file last modified time and compare with last noted value.
8. Check Tools menu and Preferences -> Sync tab.
Actual Results:  
No dialogue permitting a sync is found where expected. Settings from last Firefox session in the Preferences -> Sync tab are missing, replaced with the "Set Up Firefox Sync" button. Tools menu is also showing "Set Up Sync...".

Expected Results:  
My sync settings should have been shown in the Preferences -> Sync tab, as expected, since the prefs.js file in my profile seems to have saved those values across browser sessions.

I should also be able to sync immediately and not have to restart the setup process.

I've reproduced this behavior on 4.0b7, 8, 9, 10pre, and Minefield (2011-01-20) for OS 10.5.8 (32-bit). A fresh user profile will also reproduce the bug.
(Reporter)

Updated

7 years ago
Component: Preferences → Firefox Sync: Backend
Product: Firefox → Mozilla Services
(Reporter)

Comment 1

7 years ago
Just tested again in Minefield 4.0b11pre build 20110201030339 and it seems to be working fine now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
should be marked WFM then.  thank you for following up.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.