Closed Bug 627678 Opened 9 years ago Closed 9 years ago

Disable Crashreporter on non-GTK2 Linux builds (e.g. Qt)

Categories

(Core Graveyard :: Widget: Qt, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: romaxa, Unassigned)

Details

Attachments

(1 file, 1 obsolete file)

Attempt to compile crashreporter for qt we endup with error, like:

crashreporter.cpp:465: undefined reference to `UIFileExists(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)'
crashreporter.o: In function `CrashReporter::DeleteDump()':


Probably we should implement Qt version of crashreporter.
Practically we should implement crashreporter_gtk_common.cpp for qt
Quick npodb fix for building with simple mozconfig
Attachment #505755 - Flags: review?(doug.turner)
Comment on attachment 505755 [details] [diff] [review]
for now I suggest to disable crashreporter for non-gtk linux

Would be nice to have Qt compiled with default mozconfig.
Attachment #505755 - Flags: approval2.0?
Attachment #505755 - Attachment is obsolete: true
Attachment #505757 - Flags: review?(doug.turner)
Attachment #505757 - Flags: approval2.0?
Attachment #505755 - Flags: review?(doug.turner)
Attachment #505755 - Flags: approval2.0?
Duplicate of this bug: 604413
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 604413
Comment on attachment 505757 [details] [diff] [review]
Enable crashreporter for gtk linux only by default

this looks fine.  ted?
Attachment #505757 - Flags: review?(doug.turner) → review?(ted.mielczarek)
Attachment #505757 - Flags: review?(ted.mielczarek) → review+
Attachment #505757 - Flags: approval2.0?
Comment on attachment 505757 [details] [diff] [review]
Enable crashreporter for gtk linux only by default

npotb
Attachment #505757 - Flags: approval2.0?
Attachment #505757 - Flags: approval2.0? → approval2.0+
Patch, disable crashreporter landed :
http://hg.mozilla.org/mozilla-central/rev/d66a65c62e2e
Changing summary and resolution. A bug shouldn't be a dupe and yet have a checkin associated with it. Please change it if I've read the situation wrong.
Resolution: DUPLICATE → FIXED
Summary: Crashreporter need to be ported on Qt. → Disable Crashreporter on non-GTK2 builds
Summary: Disable Crashreporter on non-GTK2 builds → Disable Crashreporter on non-GTK2 Linux builds (e.g. Qt)
yep, this is correct. thanks.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.