Consistant crash loading this java applet.

VERIFIED WORKSFORME

Status

P3
normal
VERIFIED WORKSFORME
18 years ago
8 years ago

People

(Reporter: 1212mozilla, Assigned: edburns)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
I just got java working in Mozilla!  I've been playing around with sites that
have java today and testing my own applets to see what breaks.  I've found lots
of applets that don't run, most throw security exceptions for accessing the
sun.audio stuff.

Anyway, I went to playsite to see if I could log on and play there. To launch
they have you go to:
http://www.playsite.com/#launch
which pops up a window that basically tells you that your browser is not
supported.  The frame is hard to read, so you may need to open it in a new
window, or follow this link:
http://www.playsite.com/magicps/clientframe
From there, they invite you to try out different applets but don't guarantee
that any of them will work.  The java 1.1 client gives a ClassNotFoundException
(probably an outdated link on their part).  However the 1.0 client link seems to
be found.  The problem is that it consistently crashes mozilla.  Here is the
link again:
http://www.playsite.com/magicps/client/?force=java1.0

This was the first that my browser crashed all day.  Major, major improvements
since I first tried out Mozilla last spring. :)

I don't really have a way to tell if this is related to other OJI crashes or not...
(Reporter)

Updated

18 years ago
Keywords: crash

Comment 1

18 years ago
For me it finally loads after a long wait and then says "Start: Applet Not initiliazed" My guess is that the site is kinda funky and outdated but thats just a guess. Build here was 2000121908 M18 Trunk Build. Have you tried with the latest nightlies?
No crash for me me, linux build 2000-12-19-08.  Java console error message:

Current thread:Thread[thread
applet-playsite.shell.applet.Client,4,http://www.playsite.com/client/java1.0/-threadGroup]
OJIPlugin: No AThread

OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
 OJIPlugin release for:Thread[thread
applet-playsite.shell.applet.Client,4,http://www.playsite.com/client/java1.0/-threadGroup]
OJIPlugin releasePipe - exiting spont monitor
Current thread:Thread[thread
applet-playsite.shell.applet.Client,4,http://www.playsite.com/client/java1.0/-threadGroup]
OJIPlugin: No AThread

OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
 OJIPlugin release for:Thread[thread
applet-playsite.shell.applet.Client,4,http://www.playsite.com/client/java1.0/-threadGroup]
OJIPlugin releasePipe - exiting spont monitor
java.lang.NullPointerException
	at java.util.StringTokenizer.<init>(StringTokenizer.java:122)
	at java.util.StringTokenizer.<init>(StringTokenizer.java:138)
	at playsite.shell.applet.JSSettingsFile.read(JSSettingsFile.java:58)
	at playsite.shell.Settings.init(Settings.java:83)
	at playsite.shell.applet.Client.init(Client.java:69)
	at sun.applet.AppletPanel.run(AppletPanel.java:344)
	at sun.plugin.navig.motif.MotifAppletViewer.maf_run(MotifAppletViewer.java:127)
	at sun.plugin.navig.motif.MotifAppletViewer.run(MotifAppletViewer.java:123)
	at java.lang.Thread.run(Thread.java:484)
12/21/2000 00:01:10 * (61569) psaC: Error saving prefs
[error=java.lang.NullPointerException].
12/21/2000 00:01:10 * (61569) psaC: Error saving prefs
[error=java.lang.NullPointerException].

Comment 3

18 years ago
Stephan any luck reproducing it?
(Reporter)

Comment 4

18 years ago
Must have been the specific build I had, it no longer crashes my browser on
either linux or windows.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 5

18 years ago
Verified.
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.