Panorama thumbnails missing text with D3D9 hardware acceleration enabled

RESOLVED DUPLICATE of bug 628173

Status

()

defect
P2
major
RESOLVED DUPLICATE of bug 628173
8 years ago
8 years ago

People

(Reporter: tmeader, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

Reporter

Description

8 years ago
With D3D9 hardware accelleration enabled in Windows XP (using the latest nightlies from at least January 20th onward), when switching into Tab Candy mode, the thumbnails are missing all text in the web pages. Only the graphics appear. Likewise, the first tab opened will remain blank the entire time. Only subsequent tabs opened will display anything at all (and those will only have the graphics from the web pages displayed in the thumbnails... no text or Flash content).

Will attach screen caps.
Reporter

Comment 1

8 years ago
To clarify, in the case of "the first tab never displaying anything in its Panorama thumbnail" that isn't shown in my screen caps because I had all the tabs opened (without D3D9 accel enabled, took a screen-cap... turned on D3D9 accel, closed and reopened the browser and took a screen-cap). Seems like if tabs are loaded in from saved sessions on restart it's fine. Anyway, that probably deserves another bug. The purpose of this bug is just for the missing text (and it looks like textual HTML elements, like form fields, as well) with D3D9 on.
Reporter

Comment 2

8 years ago
Example of the way Panorama thumbnails should look.
Reporter

Comment 3

8 years ago
Here's the bug manifesting. Notice that all text and form elements from the prior image's thumbnails are missing. Only the static graphics remain.
Reporter

Comment 4

8 years ago
Almost forgot.

Adapter Description: Mobile Intel(R) 4 Series Express Chipset Family
Adapter Drivers: igxprd32
Driver Version: 6.14.10.5303
Driver Date: 9-21-2010
GPU Accelerated Windows: 1/1 Direct3D 9
Reporter

Comment 5

8 years ago
Just discovered that this also appears to be linked to the size of the thumbnails being drawn. When the thumbnails get below a certain size, the text comes back... will post a few more screen shots in a second.
Reporter

Comment 6

8 years ago
Seems that once the thumbnails go below a certain threshold in size, the text and form elements actually come back (even with D3D9 accel enabled).
Reporter

Comment 7

8 years ago
Exact same session as previous pic, but just resized the tab group box enough to enlarge the tab thumbnails slightly. Notice that all the text and form controls went away (it does seem that the site with the two tabs in the lower left is sort of still working though. Must be somehow related to something they're wrapping their content text in? www.tested.com is the site if at all interested).
(In reply to comment #5)
> Just discovered that this also appears to be linked to the size of the
> thumbnails being drawn. When the thumbnails get below a certain size, the text
> comes back... will post a few more screen shots in a second.

Is that dimension, by chance, something like 150px wide?
Reporter

Comment 9

8 years ago
Looks like it, yes. The width of the smaller thumbnails is in the mid 140s and the larger ones in the mid 150s.

Comment 10

8 years ago
yes I have this problem, the thumbnail generation is seriously overbright.

I'm guessing they are being gpu calculated though, as hardware acceleration is turned on in Options, and I haven't adjusted any about:config entries on gfx/layers for testing new builds.

The software rendered thumbs in your screenshot are better... I only get slightly better thumbnails when groups are resized smaller such that thumbnails are like 60px width.. after a certain point of resizing them larger they go really bright again. 

XpSP3, nvidia current latest drivers 480gtx

Which about:config settings are need to be adjusted to disable all gpu hardware acceleration?
Will beta 10 be released without this being fixed? :(
(In reply to comment #11)
> Will beta 10 be released without this being fixed? :(

Yes. We don't have any fix for this in the pipeline, for that matter, as it stands. We'd love to have someone work on this.

Marking P2. Windows is where the majority of our users are.
Priority: -- → P2
Duplicate of this bug: 628174
Is this a duplicate of bug 628173?

Comment 15

8 years ago
No, this is different. The tabs are not blurry in this bug: there's literally no text at all. The tab previews are blank sans the images.
Reporter

Comment 16

8 years ago
Not sure of the level of this on the release radar, but I'm wondering if this could/should at least be set to "soft blocker"? Alternatively, should D3D9 just be disabled for release on Intel cards (at least the GMA4500HD) if this isn't fixed? As it stands, if the thumbnails aren't below 150px, then it makes using Tab Candy pretty useless unfortunately.
OK, let me guess. In bug 590373 we disabled D3D10 features when we detect that Intel drivers are mis-installed (igl...dll version different from driver version in the windows registry). So now Firefox is using D3D9 layers instead, which explains why you guys with D3D10-capable chips are using D3D9 layers.

It just seems that we have to disable D3D9 layers too in this case.

Anyone who can reproduce this, can you please check the version of your  igd10umd32.dll ? Is it the same as the driver version reported in about:support?
Component: TabCandy → Graphics
Product: Firefox → Core
QA Contact: tabcandy → thebes
The usefulness of this patch still depends on replies to my question in previous comment about DLL version.
Attachment #510299 - Flags: review?(joe)
*oh* this is Windows XP so no Direct3D 10.

Can you then please still check your DLL versions, except I'm not sure what DLL this is. Anything starting in igd... may be interesting. Compare to Driver Version reported in about:support.
Attachment #510299 - Attachment is obsolete: true
Attachment #510299 - Flags: review?(joe)
Reporter

Comment 20

8 years ago
The file version reported by about:support is:

igxprd32: 6.14.10.5303

There does appear to be two Intel GL related DLLs under the XP system32 folder (with differing versions):

ig4icd32.dll: 6.14.10.5303
iglicd32.dll: 6.14.10.4926

But I'm guessing those should be unrelated to this. As for the D3D files corresponding to the one mentioned in about:support, system32 contains the following:

igxpdv32.dll
igxpdx32.dll
igxpgd32.dll
igxprd32.dll

All of these have the matching 6.14.10.5303 version number. Anything else to check?
Indeed, iglicd32.dll is the OpenGL driver so it's not relevant here.

Can you please copy to clipboard your about:support info and paste here the Graphics section?
(I mean, the info in comment 4 is missing the Device ID)
Reporter

Comment 23

8 years ago
FYI, that file that about:support says it's using is listed in the description
as "Intel Graphics 2D Rotation Driver". Doesn't seem to mention anything
specifically on D3D9. Also, from what I could find, there were no DLLs starting
with "igd" under the system32 folder. I'll search elsewhere.
Reporter

Comment 24

8 years ago
Device ID is 2a42.
Nevermind about igd*, I just don't know my Windows XP well.

OK, device 2a42 is usual HD4500.
CC'ing some gfx guys.
Reporter

Comment 27

8 years ago
DXDiag also identified:

Main Driver: igxprd32.dll

so looks like that's the only pertinent one from what I can tell. The file
isn't WHQL signed, but other than that everything passes fine (Direct Draw and
Direct3D tests, DX7-9).

It also states that the "Mini VDD" is igxpmp32.sys. Checking this file under
system32/drivers, it too has the exact same version number.

Comment 28

8 years ago
This is not just Intel, I have ATI Radeon HD 4600 and I have this bug. Driver is ati2dvag 8.812.0.0 To my knowledge, this bug affects anybody on Windows XP with acceleration turned on.
Thanks Timofei, this is very useful to know.

Bas, can you have a look at this? This looks like a legit bug in D3D9 layers, happening on ATI and Intel drivers.
blocking2.0: --- → ?
This maybe a duplicate of 628173
Reporter

Comment 31

8 years ago
Per comment 30, looking at the screenshots in bug 628173, it appears that the text content is missing in there as well for anything above 150px (just wasn't specifically noted... only the blurriness was). As long as that bug is being handled, please feel free to mark this as a dupe.
Reporter

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 628173
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.