Completing an autosuggest then pressing backspace triggers a page reload

RESOLVED WORKSFORME

Status

Firefox for Android Graveyard
General
P2
normal
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: jdm, Assigned: mfinkle)

Tracking

Trunk
ARM
Android

Details

(Reporter)

Description

7 years ago
STR:
1. turn on autocompletion
2. in the middle of a composition, press space to complete the current word
3. press backspace

expected:
extra space is removed.

actual:
page reloads.
(Reporter)

Updated

7 years ago
tracking-fennec: --- → ?
OS: Linux → Android
Hardware: x86 → ARM
(Assignee)

Updated

7 years ago
Assignee: nobody → 21
tracking-fennec: ? → 2.0+
Priority: -- → P2
(Assignee)

Updated

7 years ago
Assignee: 21 → mark.finkle
Sounds like focus is not in the textbox when the backspace is pressed. We have a page-level command the hooks the backspace key to the session history "back" action.
I could just remove the <key> that hooks this up, but that would still not make backspace work, just not reload the page
Actually, I can't reproduce this on nexus one, galaxy tab or droid pro
(Reporter)

Comment 4

7 years ago
I'll try again today on my galaxy s.  In case it matters, I was testing on crash-stats in the search field.
Some code for handling how keys are dispatched to the content has landed (http://hg.mozilla.org/mobile-browser/rev/3eea21d5b353) during the time this bug has been opened and now so Josh could you check if this happen again?
(Reporter)

Comment 6

7 years ago
Can't reproduce.  Woohoo!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.