Various problems panning/zooming gmail.com

RESOLVED WORKSFORME

Status

Fennec Graveyard
Panning/Zooming
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: cjones, Assigned: stechz)

Tracking

Details

STR
 (1) Install Phony
 (2) Clear private data
 (3) Switch to the desktop FF UA
 (4) Load gmail.com
 (5) Zoom and pan around the page

I don't reproduce any of these issues reliably, but I've seen
 - gmail stops rerendering, or rerenders at the wrong resolution, so always looks fuzzy
 - iframe width isn't calculated properly on fuzzy-zoom, so when panning to the right to a location that should have been gmail-outside-of-window, I pull in the fennec sidebar instead of seeing checkerboard
 - get an all-gray window, can't pan or zoom content back into view
 - can pan "to the right" of the scroll indicator; I see the scroll indicator go from right to left across the window
 - content process crashes

These aren't hard to trigger.
We may not block on problems with desktop gmail, since it's hard to get it to load, but the issues in comment 0 look like deeper problems with bug 605618.
tracking-fennec: --- → ?
Blocks: 605618
OS: Linux → All
Hardware: x86_64 → All
Let's identify problems related to iframe panning. We have other bugs for rendering issues.
Assignee: nobody → ben
tracking-fennec: ? → 2.0+
Ben - let's break this bug apart into smaller bugs. Some may already be filed. This bug is too "meta"
Ben needs to figure out what in this bug is a blocker and what is not.
tracking-fennec: 2.0+ → 2.0-
Reopen and file specific bugs as needed.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.