onChange event object reports destination target rather than source

VERIFIED DUPLICATE of bug 36573

Status

()

Core
DOM: Events
P3
major
VERIFIED DUPLICATE of bug 36573
17 years ago
17 years ago

People

(Reporter: Ken Mori, Assigned: joki (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)
BuildID:    20001108

When the onChange event fires and an event listener is invoked, the passed in 
event object's target attribute should specify element that the event was 
dispatched to.  However it returns the element that took focus.  This seems 
fundamental.

Reproducible: Always
Steps to Reproduce:
1.See attached
2.
3.

Actual Results:  Event handling is broken
(Reporter)

Comment 1

17 years ago
Created attachment 20653 [details]
Click create and then change the first input control.  See alerts
Reassigning to the DOM Event code owner.
Assignee: jst → joki

Comment 3

17 years ago
Is this a dup of bug 36573?
If yes please mark it, thanx.

Updated

17 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Definate Dupe of 36573 marking as such.

*** This bug has been marked as a duplicate of 36753 ***
Component: DOM Level 2 → DOM Events

Comment 5

17 years ago
Reopening because Ksosez made a typo when duplicating this bug
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

17 years ago
resolving as duplicate of bug 36573.. gotta love verifications

*** This bug has been marked as a duplicate of 36573 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
VERIFIED dup
Status: RESOLVED → VERIFIED

Comment 8

17 years ago
QA Contact Update
QA Contact: vidur → vladimire
You need to log in before you can comment on or make changes to this bug.