css error in chrome://global/skin/wizard.css

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: georg, Assigned: dao)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.17pre) Gecko/20110112 Lightning/1.0b1 SeaMonkey/2.0.12pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b10pre) Gecko/20110121

Warning: Expected end of value but found 'margin-bottom'.  Error in parsing value for '-moz-margin-end'.  Declaration dropped.
Source File: chrome://global/skin/wizard.css
Line: 33

Reproducible: Always
How is this a layout bug?  The CSS file says:

32   -moz-margin-end: 20px
33   margin-bottom: 0;

Note the missing semicolon.  This is just broken CSS.  The patch that made it broken has no bug# and no reviews.  :(
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Component: Layout: View Rendering → XUL Widgets
Ever confirmed: true
Keywords: regression
Product: Core → Toolkit
QA Contact: layout.view-rendering → xul.widgets
Dao, this is yours I think.
Assignee: nobody → dao
Assignee

Comment 4

9 years ago
Semicolon added: http://hg.mozilla.org/mozilla-central/rev/eab0007fa9d4
Status: NEW → RESOLVED
Closed: 9 years ago
Component: XUL Widgets → Themes
QA Contact: xul.widgets → themes
Resolution: --- → FIXED
Reporter

Comment 5

9 years ago
(In reply to comment #1)
> How is this a layout bug?

A I see, skin stuff is component Theme.

Nice to see that a good message in console causes a very fast fix.
Assignee

Updated

9 years ago
Duplicate of this bug: 608500
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.