Relative URLs of form "http:random_foo.html" not resolved correctly

VERIFIED DUPLICATE of bug 62624

Status

()

Core
Layout
P3
minor
VERIFIED DUPLICATE of bug 62624
17 years ago
17 years ago

People

(Reporter: Eric Barrett, Assigned: clayton)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Relative URL's of the form:

<A href="http:random_foo.html">This link doesn't work in Mozilla/5.0 (X11; U;
Linux 2.2.17-idepci i686; en-US; m18) Gecko/20001213</A>

...are not resolved correctly.  The browser takes them literally and tries to
contact the host "random_foo.html".

Comment 1

17 years ago
dupe of bug 62624 (which might itself be a dupe)

*** This bug has been marked as a duplicate of 62624 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
verified.

Yes it's itself a dupe:
dupe of wontfix bug 22251: "Relative URLs with scheme (e.g.,
http:page.html) not loading - treated as absolute"

See also similar wontfix bug 32966: "http:/ (one slash) treated as http://
rather than /"
Status: RESOLVED → VERIFIED
SPAM. HTML Element component is deprecated, changing to Layout component. See
bug 88132 for details.
Come on Bugzilla, you can do it...
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.