Flash videos that are loaded into background tabs now play automatically without focusing the tab

RESOLVED INVALID

Status

()

RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: u88484, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(Reporter)

Description

8 years ago
Flash videos that are loaded into background tabs are now played automatically even if the tab hasn't been focused.  This changed within the last two weeks.  The videos used to not play at all until the tab was made active.

STR
1) Go to Tools->Options->Tabs
2) Toggle pref "When I open a link in a new tab, switch to it immediately" to false
3) Ctrl+click this link http://www.youtube.com/watch?v=yoajdUEYBIE&feature=feedu
4) Video starts playing in the background tab
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
Latest Chrome 10.0.642.2 dev version does the same, video starts playing when opened in background.

Comment 2

8 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110124 Firefox/4.0b10pre

Confirmed. Unchecking "When I open a link in a new tab, switch to it immediately" in preferences and opening the video with Ctrl+click in background tab, plays the video even before highlighting the background tab.
This isn't us, nor is it new, really. If a Flash object is opened and set to automatically play, it automatically plays with or without focus.
Status: NEW → RESOLVED
blocking2.0: ? → -
Last Resolved: 8 years ago
Keywords: regression
Resolution: --- → INVALID
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> This isn't us, nor is it new, really. If a Flash object is opened and set to
> automatically play, it automatically plays with or without focus.

Something changed recently on a whole lot of sites then or some patch messed with a pref but I don't ever remember there being a pref to control this.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Need more context then, because youtube videos and ted talks auto-playing in background tabs is so famous as to have become a running joke, in all browsers.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.