Shark profiling hooks hang if no samples taken

RESOLVED DUPLICATE of bug 1150312

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 1150312
7 years ago
2 years ago

People

(Reporter: bz, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

STEPS TO REPRODUCE:

1)  Put the following in ~/test.js: "startProfiling(); stopProfiling();"
2)  Start shark and put it in programmatic control mode
3)  Set shark's sampling interval to 5s
4)  Build an optimized js shell with --enable-shark
5)  Run |js ~/test.js|

ACTUAL RESULTS: Shark gives an alert that says "No samples taken. [CHUDDataSource]" and the js shell hangs.  Attaching to the process in gdb doesn't work (gdb itself hangs if I try that).  Quitting shark unhangs the shell.

EXPECTED RESULTS: Get the alert, but the shell finishes execution.

ADDITIONAL INFORMATION: The hang actually happens as the shell process is trying to exit.  When it does this, ps shows its state as "UE", which means it's in an uninterruptible wait while trying to exit.
(Assignee)

Updated

3 years ago
Assignee: general → nobody
Shark builds were removed in http://hg.mozilla.org/mozilla-central/rev/926651591417 (bug 1150312)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1150312
You need to log in before you can comment on or make changes to this bug.