Flash Plug In Crashes in Normal Window when closing Pop Out video

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
--
major
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: uTest, Unassigned)

Tracking

Trunk
Other
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_6; en-us) AppleWebKit/533.19.4 (KHTML, like Gecko) Version/5.0.3 Safari/533.19.4
Build Identifier: 4.0b9

When viewing videos on this URL, if you select Pop Out under size, a small pop out video window will appear and the video you're watching will begin on that pop out window while your normal window gets paused.  If you select Play on the normal window so that both windows are playing the video, when you close the pop out window, the flash plug-in on the normal window will crash.  This only occurs on Firefox 4 Beta and does not occur on Firefox 3.6

Reproducible: Always

Steps to Reproduce:
1. Launch video on given URL
2. Select Size and Select Pop Out so that video is playing on small pop out window
3. Select Play in the normal window so that both videos are playing simultaneously and let play for a few minutes.
4. Close the Pop Out window and observe the flash plug-in crash on the normal window
Actual Results:  
Receive a Flash plug in crash message and it has option to send crash report and to reload page

Expected Results:  
Expect the video to continue playing in the normal window

This was tested also in Firefox 3.6 and closing the Pop Out window does not cause the crash in the flash plug in on 3.6.  This only occurs in 4.0.  Three crash reports were sent via the "Send Crash Report" link regarding this bug,  I will also attach the crash reports to the uTest bug report.

Comment 1

7 years ago
WFM - Mozilla/5.0 (Windows NT 5.1; rv:2.0b10pre) Gecko/20110121 Firefox/4.0b10pre ID:20110121153543

Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile

Does the issue occur with the latest nightly? http://nightly.mozilla.org/
Version: unspecified → Trunk

Updated

7 years ago
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins

Comment 2

7 years ago
Vidcaps regarding bug
URL for Crash video:  http://www.screencast.com/t/Vh1xCFbEC7
URL for working 3.6 video:  http://www.screencast.com/t/hIpKkddsc

Updates to Tim's questions coming soon.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

7 years ago
Does the issue still occur if you start Firefox in Safe Mode?
No

How about with a new, empty profile?
Issue still occurs with empty profile

Does the issue occur with the latest nightly?
No

Comment 4

7 years ago
As it doesn't occur in safe mode or a new profile there is an extension causing the issue. Please disable all extensions and re-test. See http://support.mozilla.com/en-US/kb/Troubleshooting%20extensions%20and%20themes#w_the-problem-does-not-occur-in-safe-mode

Comment 5

7 years ago
To clarify, the bug still occurs with an empty profile. We did test with extensions disabled and was still able to reproduce the bug with extensions disabled.
I was not able to reproduce this problem on the latest nightly (4.0b12pre) on Mac 10.6 and the latest version of Flash (10.2.152.26).

Comment 7

7 years ago
Reporter -> Are you still experiencing this issue with the latest version of Firefox?

Comment 8

7 years ago
Justin -> Any update?

Comment 9

7 years ago
I cannot reproduce this anymore.

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.