ShaderLinkFailureException using SceneJS on Mac OS X

RESOLVED WORKSFORME

Status

()

Core
Canvas: WebGL
--
major
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Stephen Bannasch, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b10pre) Gecko/20110121 Firefox/4.0b10pre
Build Identifier: 4.0b10pre (2011-01-21)

SceneJS is a JavaScript framework for WebGL.

Recently after upgrading to FF beta 4.8 running any of the demos produce the following error:

Error: uncaught exception: SceneJS.errors.Exception: SceneJS.errors.ShaderLinkFailureException: Shader program failed to link

The same error occurs with Minefield 4.0b10pre (2011-01-21)

The examples worked fine with earlier versions of FF/Minefield and also work fine on WebKit nightly and Chrome 9.0.597.16 dev.

Reproducible: Always

Steps to Reproduce:
1. Open page: http://scenejs.org/dist/curr/extr/examples/hello-teapot/index.html
2.
3.
Actual Results:  
Error: uncaught exception: SceneJS.errors.Exception: SceneJS.errors.ShaderLinkFailureException: Shader program failed to link

Expected Results:  
Teapot rendered in WebGL canvas

Seems to be a change in FF, not anything recent in SceneJS.

I just checked tip of the SceneJS v0.8 branch and master in a couple of places back to the beginning of Nov and can't get the basic teapot example to show up in either the latest FF beta or in Minefield.
(Reporter)

Comment 1

7 years ago
I just updated FF beta to 4.0b10 and the problem still occurs however also updated to the latest Minefield release and the shader link error is gone there.
This was probably fixed in an ANGLE update. Anyways, looks good to me!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.