Crash Report [@ js::mjit::JITScript::sweepCallICs(JSContext*, bool) ]

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
8 years ago
6 years ago

People

(Reporter: cbook, Unassigned)

Tracking

({crash})

Trunk
x86
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

8 years ago
Crash Report [@ js::mjit::JITScript::sweepCallICs(JSContext*, bool) ]
Crash-Stats url -> http://bit.ly/h5lhxf

So far no comments - all crashes are windows crashes so far

Crashing Thread

Frame	Module	Signature [Expand]	Source
0	mozjs.dll	js::mjit::JITScript::sweepCallICs	js/src/methodjit/MonoIC.cpp:1160
1	mozjs.dll	js::mjit::ReleaseScriptCode	js/src/methodjit/MethodJIT.cpp:872
2	mozsqlite3.dll	attachFunc	db/sqlite3/src/sqlite3.c:73655
3	mozjs.dll	SweepCrossCompartmentWrappers	js/src/jsgc.cpp:2180
4	mozjs.dll	PreGCCleanup	js/src/jsgc.cpp:2270
5	nspr4.dll	PR_Lock	nsprpub/pr/src/threads/combined/prulock.c:233
6	mozjs.dll	JS_GC	js/src/jsapi.cpp:2547
7	xul.dll	nsXPConnect::Collect	js/src/xpconnect/src/nsXPConnect.cpp:407
8	kernel32.dll	SystemTimeToFileTime	
9	nspr4.dll	PR_Now	nsprpub/pr/src/md/windows/ntmisc.c:357
10	xul.dll	nsXPConnect::GarbageCollect	js/src/xpconnect/src/nsXPConnect.cpp:415
11	xul.dll	nsJSContext::CC	dom/base/nsJSEnvironment.cpp:3630
12	xul.dll	nsJSContext::IntervalCC	dom/base/nsJSEnvironment.cpp:3735
13	xul.dll	nsJSContext::MaybeCC	dom/base/nsJSEnvironment.cpp:3704
14	xul.dll	GCTimerFired	dom/base/nsJSEnvironment.cpp:3761
15	xul.dll	nsTimerImpl::Fire	xpcom/threads/nsTimerImpl.cpp:425
16	nspr4.dll	PR_ExitMonitor	nsprpub/pr/src/threads/prmon.c:132
17	xul.dll	nsTimerEvent::Run	xpcom/threads/nsTimerImpl.cpp:517
18	xul.dll	nsThread::ProcessNextEvent	xpcom/threads/nsThread.cpp:633
19	nspr4.dll	PR_AssertCurrentThreadOwnsLock	nsprpub/pr/src/threads/combined/prulock.c:404
20	nspr4.dll	PR_AssertCurrentThreadOwnsLock	nsprpub/pr/src/threads/combined/prulock.c:404
21	xul.dll	mozilla::ipc::MessagePump::Run	ipc/glue/MessagePump.cpp:110
22	xul.dll	MessageLoop::RunInternal	ipc/chromium/src/base/message_loop.cc:219
23	xul.dll	MessageLoop::RunHandler	ipc/chromium/src/base/message_loop.cc:202
24	mozcrt19.dll	_VEC_memzero	
25	xul.dll	xul.dll@0x35dcad	
26	xul.dll	MessageLoop::Run	ipc/chromium/src/base/message_loop.cc:176
27	xul.dll	nsBaseAppShell::Run	widget/src/xpwidgets/nsBaseAppShell.cpp:192
28	xul.dll	xul.dll@0xb20297	
29	xul.dll	nsAppStartup::Run	toolkit/components/startup/src/nsAppStartup.cpp:191
30	xul.dll	XRE_main	toolkit/xre/nsAppRunner.cpp:3695
31	firefox.exe	wmain	toolkit/xre/nsWindowsWMain.cpp:128
32	firefox.exe	__tmainCRTStartup	obj-firefox/memory/jemalloc/crtsrc/crtexe.c:591
33	kernel32.dll	BaseProcessStart
If amd64 means that we're running the 64-bit build, as I believe it does, this is now a Win64-only crash since the Feb 14 build.
Dupe of bug 624406?
Crash Signature: [@ js::mjit::JITScript::sweepCallICs(JSContext*, bool) ]
JM is gone.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.