Closed Bug 62845 Opened 19 years ago Closed 17 years ago

<HR> does not break line for justification purposes

Categories

(Core :: Layout, defect, P4, minor)

defect

Tracking

()

RESOLVED WORKSFORME
mozilla1.0.1

People

(Reporter: sergiojr, Assigned: ian)

References

()

Details

(Keywords: testcase, Whiteboard: [Hixie-P4] [fix in hand] fixed with bug 38370 (py8ieh: file new bug for generated content case))

Attachments

(1 file)

align="JUSTIFY"
 leaves too much space between words. So they are not easy to read
changing to element
Component: Layout → HTML Element
QA Contact: petersen → lorca
What buildID are you using? Thanx.
Noted same on my browser for the above .ru URL.

Mozilla/5.0 (X11; U; Linux 2.2.16-22 i686; en-US; m18) Gecko/20001214

Words are spaced too far apart. I suspect this is true regardless of  language,
but can't test that at the moment. I don't know what kind of algorithm is used
to determine justifying, but worth a look into? 
H-J's Tips:
1 - According to HTML standards, each HTML document requires a document type
declaration. Consider visiting:
http://www.htmlhelp.org/tools/validator/doctype.html for further information. A
HTML page needs something like this:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">

By putting this in, no problem!

2 - use lowercase element names only.
3 - Validate your pages at: http://validator.w3.org/check
4 - Also try to consider to use the tool Tidy. You may find that, for free, at:
    http://www.w3.org/People/Raggett/tidy/
5 - the way the author is using font, is not a good work!

Used build, 2000121104 on WinNT4 Sp6b.
Friendly, HJ.
But why not to use the most "powerful" doctype if it's not mentioned in document.
Actually, Mozilla may be doing the right thing here.  Align="JUSTIFY" means that
the text is to be flush with the left _and_ right margin. From the CSS
specification (http://www.w3.org/TR/REC-CSS2/text.html#alignment-prop):

In the case of 'justify', the UA may stretch the inline boxes in addition to
adjusting their positions. (See also 'letter-spacing' and 'word-spacing'.)

And (http://www.w3.org/TR/REC-CSS2/text.html#propdef-word-spacing):

Word spacing algorithms are user agent-dependent. Word spacing is also
influenced by justification (see the 'text-align' property).

Since align="justify" merely sets the CSS text-align property on the text in the
table cell, it looks like Mozilla is doing exactly what the CSS spec says it should.
If W3C says "Word spacing algorithms are user agent-dependent," wouldn't it make
sense for Mozilla to take the initiative to treat certain-length lines as
non-justified? Say you have two words orphaned on the last line of a paragraph
whose average words per line is 15 or 20. Would you align those two words flush
to left and right, leaving a giant blank space in the middle?

I think that's the issue to consider here. I don't have a good answer or
suggestion at the moment, but I do see the problem...
From my faint memories of Typing 101, JUSTIFY should only be valid on lines that 
do not have  <CR>, in HTML, that would mean something like <P> or </P>...Any more 
thoughts?
->buster, cc: roc
Assignee: clayton → buster
Component: HTML Element → Layout
I think justify is working as minimally required and described by CSS2.
However, there are some typographic conventions that we could implement as
enhancements.  I think that's what is being asked for here.

I will not have any time to look at this any time soon.  Assigning to Robert in
case he's interested.   Marking helpwanted in case anybody is interested enough
to take this on.  Also noting the low priority and enhancement nature of the
request.
Assignee: buster → roc+moz
Severity: normal → enhancement
Keywords: helpwanted
Priority: P3 → P4
There is a real bug here, we shouldn't be justifying lines that end in <BR>.
Accepting bug.
Severity: enhancement → minor
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: helpwanted
Priority: P4 → P3
Actually it's not <BR> --- <HR> is not breaking the line for justification purposes.
Changing summary.
Summary: align="JUSTIFY" work in a wrong way → <HR> does not break line for justification purposes
Sounds like another bug that will be completely fixed by fixing bug 38370:
can't change <HR> and <BR> color.
Depends on: 38370
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok
OS: Windows 2000 → All
Hardware: PC → All
Target Milestone: --- → mozilla1.0
this is fixed in my build using the fix in bug 38370
Assignee: roc+moz → ian
Status: ASSIGNED → NEW
Keywords: testcase
Whiteboard: [Hixie-P4] [fix in hand] fixed with bug 38370 (py8ieh: file new bug for generated content case)
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1
*** Bug 147707 has been marked as a duplicate of this bug. ***
QA Contact: gerardok → praveenqa
QA Contact: praveenqa → dsirnapalli
The fix under 38370 must have been checked in. Both the URL and the testcase are
WFM in latest nightlies (2003081304). (Continuing sweep of old <hr> bugs...)
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → WORKSFORME
Thanks for doing this sweep, Bruce.
You need to log in before you can comment on or make changes to this bug.