Exception in nsIXMLHttpRequest.open on amazon.de

RESOLVED DUPLICATE of bug 626041

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 626041
8 years ago
8 years ago

People

(Reporter: Jan Günter, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fx4-fixed-bugday], URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

When I try to use the shipment tracking of amazon.de I get the following error:

Exception...
"Component returned failure code: 0x805e0006 [nsIXMLHttpRequest.open]" 
nsresult: "0x805e0006 (<unknown>)" 
location: "JS frame :: http://www.jan-guenter.de/ff4bug/jQuery-amazon.js :: <TOP_LEVEL> :: line 1553" 
data: no

I constructed a small example to reproduce the error (http://www.jan-guenter.de/ff4bug/). It uses exact the same amazon-modifyed jQuery lib, but I reformatted it for easier debugging.

I've tested it on Win7 64bit and Win XP 32bit.
Working in FF3 as well as any other modern browser.

Reproducible: Always

Steps to Reproduce:
1. open up http://www.jan-guenter.de/ff4bug/
2. click the test link
3. find the exception in the log
Actual Results:  
an exception occures
(Reporter)

Updated

8 years ago
See Also: → bug 626041
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Whiteboard: [fx4-fixed-bugday]
Duplicate of bug: 626041
You need to log in before you can comment on or make changes to this bug.