Strange underlining behavior

VERIFIED INVALID

Status

()

Core
Layout
P3
normal
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: Nikos Platis, Assigned: clayton)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
The attached file contains two links and some fiddling with styles and mixing tags.
In NS and IE the first link is rendered with no underlining and the second
underlined.
In Mozilla both links are underlined.

Which behavior is correct? Is it related to Bug 1777 ?

(The testcase is adapted from some existing page, which contained only the first
set of HTML tags and appeared undecorated in NS but (uglily) underlined in Mozilla)
(Reporter)

Comment 1

17 years ago
Created attachment 20703 [details]
Testcase
This is related to bug 1777 in that this is actually the part of the issue
covered in 1777 that works correctly.  The CSS specification says at
http://www.w3.org/TR/REC-CSS2/text.html#lining-striking-props that the
text-decoration property spans children.  Mozilla's handling is correct -- the
underline of the <a> spans the <strong> and its enclosed text.  IE and Netscape
both handle this wrong.  If someone wants to have no text-decoration on text
inside a link, they need to set "text-decoration:none" on the <a> element
itself.

Marking invalid, since Mozilla is doing what it should be.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 3

17 years ago
See also bug 10458.
VERIFIED invalid.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.