Closed Bug 628735 Opened 10 years ago Closed 6 years ago

Firefox 4.0b10pre crash [@ JSScript::getGlobalSlot(unsigned int) ]

Categories

(Core :: JavaScript Engine, defect)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 685315

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash)

Crash Data

Seen while reviewing crash stats.

http://tinyurl.com/4w8uyv6 to the crashes which are all Windows. There were some crashes in Beta 9 but in small volume. The latest trunk shows 177 crashes in this stack in one week.

Frame 	Module 	Signature [Expand] 	Source
0 	mozjs.dll 	JSScript::getGlobalSlot 	js/src/jsscript.h:538
1 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4060
2 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:657
3 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:737
4 	mozjs.dll 	js::ExternalInvoke 	js/src/jsinterp.cpp:858
5 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5009
6 	xul.dll 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:2180
7 	xul.dll 	nsGlobalWindow::RunTimeout 	dom/base/nsGlobalWindow.cpp:9048
8 	xul.dll 	nsGlobalWindow::TimerCallback 	dom/base/nsGlobalWindow.cpp:9393
9 	xul.dll 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:425
10 	xul.dll 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:517
11 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:633
12 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:134
13 	xul.dll 	xul.dll@0xb26293 	
14 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:202
15 	mozcrt19.dll 	_VEC_memzero 	
16 	xul.dll 	xul.dll@0x35f15d 	
17 	firefox.exe 	firefox.exe@0x1bb7 	
18 	ntdll.dll 	WinSqmSetIfMaxDWORD 	
19 	ntdll.dll 	_RtlUserThreadStart 	
20 	firefox.exe 	firefox.exe@0x186f 	
21 	firefox.exe 	firefox.exe@0x186f
The majority of these crashes are all on Win 7 hardware. In the last week I only see one Win Vista crash.
I found a possible way to reproduce this bug:

1) Install Load [url=https://addons.mozilla.org/en-US/firefox/addon/load-tabs-progressively/versions/]Tabs Progressively 1.6[/url] or 1.61pre to a Nightly build.
2) Open this feed with Google Reader: http://www.megaleecher.net/rss.xml (just an example, I have many feed that crash).

It should crash your browser.

Crash report example: https://crash-stats.mozilla.com/report/index/bp-6b031623-c3db-4f5c-9ca1-948a52110530
Bug related: https://bugzilla.mozilla.org/show_bug.cgi?id=628735

Now the question is, the extension need to be updated or the bug?


Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110530 Firefox/7.0a1
The right link to extension above is https://addons.mozilla.org/en-US/firefox/addon/load-tabs-progressively/versions/

Bugzilla need to add a way to user edit their posts (bug 540).
(In reply to comment #2)
Your crash report indicates that 81 other extensions were installed too. Could you repeat your test with a profile that has only LTP installed and post the crash report?
Sorry, for the poor report example. I was able to reproduce this problem in a new profile, I forgot to get the right link. I tried a new profile again, similar behavior, but a different crash:

https://crash-stats.mozilla.com/report/index/bp-84d61d90-db1e-4738-b3a6-eb8dc2110530

Firefox 7.0a1 Crash Report [@ mozjs.dll@0x4255c ]

Browser restarted several times, but don't crash anymore. I'm confused now! Anyway, if I found a way to reproduce it again I will report here.

Sorry for wasted your time here.
Crash Signature: [@ JSScript::getGlobalSlot(unsigned int) ]
Assignee: general → nobody
getGlobalSlot was removed in https://hg.mozilla.org/mozilla-central/rev/dfe8e0b73453 (bug 685315)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 685315
You need to log in before you can comment on or make changes to this bug.