New property to mark an extension not compatible with a version of Firefox

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
RESOLVED INVALID
7 years ago
21 days ago

People

(Reporter: willyaranda, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b10pre) Gecko/20110124 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b10pre) Gecko/20110124 Firefox/4.0b10pre

I'm seeing a lot of problems with Add-on Compatibility Reporter:

https://addons.mozilla.org/es-ES/firefox/addon/add-on-compatibility-reporter/reviews/

Mostly this:

----

por johnjbarton el January 6, 2011 #

Now we have 3000 unhappy Firebug users because they used this hack tool to use Firebug 1.6 on Firefox 4.0. We set the compatibility setting to Firefox 3.6 because Firebug 1.6 DOES NOT WORK with Firefox 4.0. This tool ought to be banned.

----

There are some extension versions that are not compatible with a version of Firefox because the developer wants it.

The extensions.checkCompatibility.VERSION should not enable that extension if it matches this new property in the intall.rdf, for example

<em:minVersionNotCompatible>3.7a1pre</em:minVersionNotCompatible>

and the extensions.checkCompatibility.3.7a is configured, the extension should not be enabled.

Reproducible: Always

Comment 1

7 years ago
(In reply to comment #0)
...
> por johnjbarton el January 6, 2011 #
...
> There are some extension versions that are not compatible with a version of
> Firefox because the developer wants it.

I just want to clarify that every single version of Firefox in the last four years has a 'compatible' version of Firebug.  In some cases Firefox is to broken to correctly support Firebug.

The problem with the Add-on Compatibility Reporter is that it is being applied to the wrong versions of Firebug. The correct version of Firebug for Firefox 4.0 is Firebug 1.7. The Add-on Compatibility Reports about running Firebug 1.6 on Firefox 4.0 should never happen.

Rather than fix the Add-on Compatibility Reporter, as simpler solution is to fix AMO so that Firefox 4.0 users get Firebug 1.7 and Firefox 3.6 users get Firebug 1.6.  We're going to fix this ourselves in Firebug 1.8, I wish we could do it sooner.

Comment 2

21 days ago
Legacy extensions are no longer valid and with it most of these compatibility problems.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 21 days ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.