bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

/beta path is doubled on /sites

VERIFIED FIXED in 3.1

Status

Input
General
--
major
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: stephend, Assigned: davedash)

Tracking

({regression})

Trunk
regression

Details

(URL)

(Reporter)

Description

8 years ago
STR:

1. Load http://input.stage.mozilla.com/en-US/beta/
2. Click on "Sites"

Expected Results:

http://input.stage.mozilla.com/en-US/beta/sites

Actual Results:

http://input.stage.mozilla.com/en-US/beta/beta/sites

(Double your betas, double your fun!)
Possible that today's merge (from development to master) broke something. I'll be at a class all day tomorrow. Dave Dash, can you take a look?
Actually this is because the URL patterns for Sites have not been adapted to davedash's channel middleware yet.

Assigning this one to Michael: You want to remove the "beta/" from your URL patters in website_issues.urls, and instead hook up two views (one for beta, one for releases) to the same URL using the negotiate() function that Dave wrote for this purpose. Take a look at feedback.views to see how it works, and let me or Dave know if you have any questions!
Assignee: nobody → michael
Depends on: 623359
Removed the depenency (it's totaly fixable before we have the release dashboard).
Thanks dave for taking this on, leaving it for you to mark fixed.
Assignee: michael → dd
No longer depends on: 623359
http://github.com/fwenzel/reporter/commit/6a43400
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

8 years ago
Verified FIXED; thanks, guys -- our Hudson build went green: http://qa-selenium.mv.mozilla.com:8080/job/input%20stage/213/
Status: RESOLVED → VERIFIED
Component: Input → General
Product: Webtools → Input
You need to log in before you can comment on or make changes to this bug.