No ABI specification possibility for plugin loading in the Firefox 4.0

RESOLVED WONTFIX

Status

()

Core
Plug-ins
--
major
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: Zbynek Michl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; cs-CZ; rv:1.9.1.16) Gecko/20110107 Iceweasel/3.5.16 (like Firefox/3.5.16)
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

There is no alternative for arch specification when loading plugin from an extension package in the FF 4.0.

Firefox <=3.6 provides directory structure as follows:
/platform/Linux_x86-gcc3/plugins/libMyPlugin.so
/platform/WINNT_x86-msvc/plugins/MyPlugin.dll
/platform/Darwin_ppc-gcc3/plugins/libMyPlugin.dylib

...but this has been removed in the Firefox 4.0.


Reproducible: Always

Steps to Reproduce:
1. Install FF 4.0bX
2. Create an extension with NPAPI plugin and place it into /platform/{OS_TARGET}_{TARGET_XPCOM_ABI}/plugins/libMyPlugin.(so|dll|dylib)
3. Install the extension

Actual Results:  
Plugin does not load in FF 4.0.


Expected Results:  
Plugin should load from above directory structure or should be possible define the plugin path in the chrome.manifest file like this:

plugin plugins/Linux/libMyPlugin.so ABI=Linux_x86-gcc3


More about this topic is available at http://groups.google.com/group/mozilla.dev.tech.plugins/browse_thread/thread/c72c551dd909cb9d

Comment 1

7 years ago
We removed this intentionally. For plugins, you can just put them all the plugins/ folder, and we'll only load the ones which are compatible with the running architecture.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

7 years ago
Ok, I wasn't sure if this is the right way since I'm getting many "LoadPlugin: failed to initialize shared library..." messages while running the Firefox.
You need to log in before you can comment on or make changes to this bug.