Unexpected behavior when adjusting column width in about:config page

RESOLVED INVALID

Status

()

Toolkit
XUL Widgets
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: linostar, Unassigned)

Tracking

({rtl})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Only rtl locales are affected by this bug. When you put the mouse on the left side of a column (as opposite to the right side of the column for ltr locales), you should be able to adjust the width of that column. However, the column which the width is changed is the column next to it (on its left). Not only this behavior is unaccounted for, it also makes adjusting the width of the first column impossible.

I expect that other Excel-like pages in Firefox (if there is any) may suffer from the same issue.
(Reporter)

Updated

7 years ago
Keywords: rtl

Comment 1

7 years ago
This looks like a problem in the tree widget, over to toolkit xul. If any of the other two xul components work better, that's fine with me ;-)

Anas, do you know if this is a regression in 4.0 or if that's already this way in 3.6?
Component: General → XUL Widgets
Product: Firefox → Toolkit
QA Contact: general → xul.widgets

Comment 2

7 years ago
Which version of Firefox are you using?  I thought that I had fixed the issue in bug 176244...
(Reporter)

Comment 3

7 years ago
Same as bug 628640:

The bug appeared in an up-to-date local build in linux x64.

I tested both 3.6.13 and 4.0b9 on win32, and they appear clean of this issue.

I don't know about 3.6 on linux, since there is no localized builds of ff3.6 for linux x64.

That means that the cause if this bug is something related to the linux interface (or the x64 build). Of course there is a small chance that something made a mess between 4.0b9 and the latest trunk.
(Reporter)

Updated

7 years ago
OS: All → Linux
Hardware: All → x86_64

Comment 4

7 years ago
Can you please test the latest English 3.6 and 4.0beta builds on Linux with the Force RTL extension, and let me know if they're affected?  You can get Forece RTL from <https://addons.mozilla.org/addon/force-rtl/>.
(Reporter)

Comment 5

7 years ago
Both were OK, and more importantly the build in which I found the bug is OK too. I am frightfully sorry about this, but it seems I was little drowsy when I thought the resizing behavior was strange.

I apologize again, and I'll mark the bug as invalid.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.