Closed Bug 628979 Opened 10 years ago Closed 9 years ago

Restore tabs / session is not consistent

Categories

(Firefox for Android Graveyard :: General, defect, P4)

ARM
Android
defect

Tracking

(fennec-)

RESOLVED DUPLICATE of bug 630398
Tracking Status
fennec - ---

People

(Reporter: ioana.chiorean, Unassigned)

Details

(Whiteboard: [fennec-sessionstore])

Build Identifier: Mozilla/5.0 (Android; Linux armv7l; rv:2.0b11pre)
Gecko/20110126 Firefox/4.0b11pre Fennec/4.0b4pre 
Device HTC Desire A8181

Steps to reproduce:
1. Open more than one tab
2. Kill the application
3. Open the application
4. Open all tabs 
5. Kill the application
6. Open the application

Expected result:
- the about:home appears with a list of tabs from last session

Actual result:
- First time (step 3) a page about:home appears as expected.
- Second time (step 6) all tabs from last time are opened in separates tabs. 

Note:
- if we want to make all tabs restored, we shall do that at first time to
- if we want a behavior as on desktop, we shall first restore all tabs and after, at next killing to open a page about:home with the list of tabs from last session.
- please see video : http://www.youtube.com/watch?v=jvlS5y0HjYc
Mark, any ideas about what's happening here?
Looks like the session from the first set of steps was not saved or not loaded so the restore in step #3 failed. That sounds like a bug, and we might have one like that filed already.

We never open about:home when restoring session. That would be a separate feature request.
tracking-fennec: --- → 2.0-
Priority: -- → P4
Whiteboard: [fennec-sessionstore]
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Whiteboard: [fennec-sessionstore] → [fennec-6] [fennec-sessionstore]
Duplicate of bug: 630398
Whiteboard: [fennec-6] [fennec-sessionstore] → [fennec-sessionstore]
You need to log in before you can comment on or make changes to this bug.