Text is not smooth on Mac OS X

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: andreea.pod, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
Created attachment 507109 [details]
about:support

Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b10pre) Gecko/20110125 Firefox/4.0b10pre

Go to any site (e.g. bugzilla.mozilla.org, www.cnn.com) and look closely at the text. The problem is easily visible at the "t" and "e" letters. I attached the contents of about:support and a screenshot.
(Reporter)

Comment 1

8 years ago
Created attachment 507110 [details]
screenshot
Component: General → Graphics
Product: Firefox → Core
Do you know when this started happening?
A regression window could be helpful.
http://quality.mozilla.org/docs/bugzilla/guide-to-triaging-bugs-for-firefox/finding-a-regression-window/

Does setting layers.acceleration.disabled to true in about:config, help?
(Reporter)

Comment 3

8 years ago
Tried today to find the regression window but no result. I installed very old builds (2008 or 2007) but the text looks the same. Like I said in comment 38 on bug 582223 I see this in Safari too.
(Reporter)

Comment 4

8 years ago
And setting layers.acceleration.disabled to true is not helping.
AIUI firefox and Safari look like this but other apps don't.
Can you find an app where it looks how you think it should and experiment with different sizes to see if it always looks right?
Can you get a screenshot of text in the same font and size from another app where it looks better?
Or try changing the monospace font in Preferences, Content, Fonts & Colors, Advanced.
(Reporter)

Comment 7

8 years ago
Created attachment 507408 [details]
text comapre

I have set the font and size in mail app like in the test text (https://bug582223.bugzilla.mozilla.org/attachment.cgi?id=460558). The text looks the same (see screenshot), so this is a problem of font and size?
The screenshot in comment #2 shows the text using grayscale instead of subpixel antialiasing, which is why it looks rough. But it's not clear to me why that's happening; I get subpixel AA here.
QA Contact: general → thebes
Even with subpixel AA on, it looks rough because the horizontals are not hinted.
See for example e, f, p, and l, in attachment 502838 [details] (ignoring the off-by-one pixel scrolling artifacts).

FreeType hints these stems.  Do Apple's rasterizers have similar trouble with all fonts or is there another font we can choose for the default that has hints in the format that Apple likes?
Are there specific instances of e, f, p, and l you're referring to? AFAIK, CoreGraphics doesn't use font hints at all, it simply antialiases everything, maintaining "ideal" outlines. In attachment 502838 [details], the text looks as I'd expect, except for the (many) scrolling artifacts where pixel rows are duplicated or omitted. Some of those end up looking like poorly-rasterized glyphs, it's true.
OS: Mac OS X → Windows 7
No, not specific instances.  To me they all show the same issues as the t and e in the reporter's screenshot.  (If this were a grayscale/RGB aa issue then t and e are no different to the other letters.)

I wondered whether there was a little hinting happening because the horizontals on the baseline look fine and the tops of lowercase letters looked aligned, but maybe that was just good luck.  You are probably right that there is no hinting at all.
Andreea, font rendering preferences differ widely among different users.
Some like bitmap fonts, some like no alignment of stems at all and prefer to "imagine" where the character outlines are.
From an application perspective, it's usually best to go with what the rest of the system usually does.  If the app looks different to the rest of the system it feels unusual to most users.

I'll mark this WONTFIX for now, because Firefox is following what the rest of the system does.  (I think this behavior is typical for a Mac desktop with LCD antialiasing disabled.  You may like to try playing with system settings to see whether they can make things look better.)

If you can identify a way that Firefox is behaving differently from other apps, then we'll be interested in that.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
OS: Windows 7 → Mac OS X
You need to log in before you can comment on or make changes to this bug.