If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Show preview of tabs in Windows 7 taskbar does not display all opened pages

RESOLVED INVALID

Status

()

Firefox
Shell Integration
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: George Carstoiu, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110125 Firefox/4.0b10pre

Having the "Show tab previews in Windows taskbar" option checked and opening more than 20 tabs creates a preview only for the last opened tab.

Reproducible: Always

Prerequisites:
 - Options|Tabs ->  Show tab previews in Windows taskbar is checked

Steps to reproduce:
 1. Open 5 tabs, hover with mouse over Firefox button in taskbar and observe behavior 
 2. Open more than 20 tabs and observe behavior again

Actual results:
 - preview is displayed for the last opened tab

Expected results:
 - even if there are more than 20 pages opened, the list with all the opened tabs should be displayed (if list is too big to fit screen, scroll buttons should appear)

Comment 1

7 years ago
It should be displaying a vertical list of tab titles when the number of tabs exceed the width of the tab bar. On my W7 system this behaves as expected.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110125 Firefox/4.0b10pre
Built from http://hg.mozilla.org/mozilla-central/rev/6a097e294828

Comment 2

7 years ago
Yes, as you get the 21st tab the Windows task bar shifts from the stacked window/tab style to the single window style. Using the trunk build or b10.
This is on purpose. You can change this setting by going to about:config and changing the value of browser.taskbar.previews.max

Hope this helps
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

7 years ago
I understand Felipe, but this could be problematic for the average user who doesn't know how to change that variable. For him/her it would just look like an abnormal behavior. (Opera has similar feature, which is not limited by default to 20 opened tabs - just to have a look at the competition)

Comment 5

7 years ago
(In reply to comment #3)
> This is on purpose. You can change this setting by going to about:config and
> changing the value of browser.taskbar.previews.max
> 
> Hope this helps

Where can I change this value exactly? Because I loved  the prevarious version of Mozilla FF that fire fox displayed all this tabs.

tnx any way
type about:config in the address bar then use the filter line to find browser.taskbar.previews.max

Comment 7

7 years ago
tnx
You need to log in before you can comment on or make changes to this bug.