Bookmark names unnecessarily truncated with ellipses

RESOLVED DUPLICATE of bug 627824

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 627824
7 years ago
7 years ago

People

(Reporter: Rich Parker, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10) Gecko/20100101 Firefox/4.0b10
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

As of Beta 10, several of my bookmarks are being cut off with ellipses when there's plenty of space to show the entire name.  See screen shots.

Firefox hardware acceleration enabled, Windows ClearType disabled, menu font Verdana 8.

Reproducible: Always
(Reporter)

Comment 1

7 years ago
Created attachment 507144 [details]
Student Loan Corporation -> Student Loan Corporati...
(Reporter)

Comment 2

7 years ago
Created attachment 507146 [details]
W3Schools Online Web Tutorials -> W3Schools Online Web W3Schools Online Web Tutori...
(Reporter)

Comment 3

7 years ago
Created attachment 507149 [details]
University of Florida -> University of Flori...
Is this a regression from beta 9?
Component: Bookmarks & History → Menus
QA Contact: bookmarks → menus
(Reporter)

Comment 5

7 years ago
Confirmed, not an issue in Beta 9, started in Beta 10.  There are also some relevant comments in Bug 622507.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression, regressionwindow-wanted
And just to check, could you confirm that this issue goes away if you set gfx.font_rendering.harfbuzz.level=0 in about:config (and restart the browser)?

And also that it goes away if you set gfx.direct2d.disabled=true (even if you leave harfbuzz.level at 2)? Note that I think your window may appear to freeze when you toggle direct2d.disabled to true; just resize it slightly to bring it back to life.
(Reporter)

Comment 7

7 years ago
No, bookmarks are still truncated after changing harfbuzz.level to 0 and restarting.  However, setting direct2d.disabled to true does "fix" the problem.
(In reply to comment #7)
> No, bookmarks are still truncated after changing harfbuzz.level to 0 and
> restarting.

Ok, that's interesting, thanks.

>  However, setting direct2d.disabled to true does "fix" the problem.

And if you then set gfx.font_rendering.directwrite.enabled to true (while D2D is still disabled) and restart, does the problem reappear?
(Reporter)

Comment 9

7 years ago
(In reply to comment #8)
> And if you then set gfx.font_rendering.directwrite.enabled to true (while D2D
> is still disabled) and restart, does the problem reappear?

Yes.
looking at the description of the 2 bugs, this sounds really the same as bug 627824. I'm duping to that one, please have a look in case I missed something.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 627824
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.