Last Comment Bug 629053 - Add .lv to IDN TLD whitelist
: Add .lv to IDN TLD whitelist
Status: RESOLVED FIXED
: verified1.9.2
Product: Core
Classification: Components
Component: Networking: Domain Lists (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Gervase Markham [:gerv]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-26 10:24 PST by Gervase Markham [:gerv]
Modified: 2011-06-16 15:21 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.x-fixed
.18-fixed
.20-fixed


Attachments
Adds .LV to the IDN Whitelist (914 bytes, patch)
2011-05-23 11:52 PDT, Jothan Frakes
dveditz: approval2.0+
dveditz: approval1.9.2.18+
dveditz: approval1.9.1.20+
Details | Diff | Splinter Review

Description Gervase Markham [:gerv] 2011-01-26 10:24:43 PST
Dear Mr Markham, 

I am writing you on behalf of the University of Latvia, Institute of Mathematics and Computer Science, Network Solutions Department, the Registry of the ccTLD .LV (Latvia).

Recently we have received several complaints from Firefox users that .LV IDN domains are converted to punycode once Firefox opens the site. We offer IDN.LV registrations since March 2004 and you can find the list of allowed diacritical letters used in our domain at http://www.nic.lv/resource/show/53  article 1.11. and 6.1.3.

We would be happy if you could add .LV ccTLD to the list of IDN-enabled TLDs. Please let us know if there is any additional information you require.

Kind regards,

Katrina Sataki
Manager
NIC.LV – The Registry of ccTLD .lv
Institute of Mathematics and Computer Science,
University of Latvia
Raina bulvaris 29, Riga LV-1459
Tel: +371 67085858, Fax: +371 67225072
www.nic.lv
Comment 1 Gervase Markham [:gerv] 2011-01-26 10:26:13 PST
I have read the policy and this is fine.

Gerv
Comment 2 Jothan Frakes 2011-05-18 16:22:47 PDT
Katrina is the correct person for .lv, I have met her at ICANN.  I will make a patch to roll this in and link to this bug
Comment 3 Jothan Frakes 2011-05-23 11:52:53 PDT
Created attachment 534504 [details] [diff] [review]
Adds .LV to the IDN Whitelist

Katrina is the authorized representative, the university is the listed IANA contact.

Terms and Conditions of registration are here:
http://www.nic.lv/resource/show/97

The Registration Policy
http://www.nic.lv/resource/show/53

item 6.1.3 specifically lists the special characters that are allowed.
Comment 4 Gervase Markham [:gerv] 2011-05-23 12:49:12 PDT
http://hg.mozilla.org/mozilla-central/rev/606fca215fb8

Gerv
Comment 5 Daniel Veditz [:dveditz] 2011-06-01 10:28:49 PDT
Comment on attachment 534504 [details] [diff] [review]
Adds .LV to the IDN Whitelist

Approved for 1.9.2.18 and 1.9.1.20, a=dveditz for release-drivers
Approved for the mozilla2.0 repository, a=dveditz for release-drivers
Comment 7 Al Billings [:abillings] 2011-06-16 15:21:45 PDT
Verified in source for 1.9.2.18.

Note You need to log in before you can comment on or make changes to this bug.